Colored glass-shadows missing details

I noticed that colored shadows (in cycles) not matching the objects very well. Is there some kind of limit in the shadow resolution? Details are missing as visible here in my quick Test-Scene.

I tried an “insane” amount of samples or raising max. bounces for glossy and others. But that does not have any effect on the shadows.

Are there ways of improving and changing something on the shadow-resolution?

Oh - now i found that setting “Filter Glossy” to 0 from 1 (in the caustics section of the render properties) makes a hugh difference and inprovement to the shadows. Appears way more accurate now. The shattered glass to the left has even some kind of refraction in the shadow.

But still not perfect. Are there more or other settings to improve this?

1 Like

-First, I would try going in the lamp’s settings and play with the radius, as it seems you have rather soft shadows.

-If that’s not enough, I would try using the “light path” node to give your glass material fake shadows, as cycles is not good at rendering light that’s going through glass.