colors looking grey

This is one thing I haven’t been able to figure out. Why does every color I try to create look grey? No matter how I play with the settings my colors don’t turn out the way the look in the materials sample window.

Someone said to play with the lights but I could never figure out what that means.


Can you post an image and or a blend?
It could be allot of things , a reflection of a grey world, off color lights, not bright enough lights, even a bad monitor. It sounds frustrating but probably easy to fix if you provide some more info.

Here is a shot of the settings I used to get the render. I did one without the image and had a similar problem (except I kept playing with it and lost the settings!). The color was a little better but there was grey in the sample material screen. I am pretty sure that my problem comes from confusion about what to do with all the color sliders in different places, materials tab, textures tab, and the map to tabs.

Why are there so many of these amd why are they in different places. When I use them and something comes out looking good I’m not really sure what I did right and what was just dumb luck.



Try using another texture, maybe is the one you use too bright.

If not, you may have turned your lights energi too high!

Last options is too post a blend, then i’ll have a look :slight_smile:

By playing with the lights, they mean to select the light in object mode and make changes to it, changing it to a different kind of light, etc.
Positioning the light, and duplicating it to position a light behind/underneath, can make some differences.
Also, changing settings in your material can affect your color - emit can make it give off a kind of light , and turning the hardness up or down can change the output.
I find that the default light set up always needs to be changed, because it isn’t geared for my choices. I usually change at least one light into a spot light, then mess around with the color of the light itself. You could also try an area light, and see if that helps. Ususally, colors look grey if there isn’t enough - I’ve noticed that my whites always look grey until I light the scene up.
Good texture, BTW.
Happy blending!!

That looks more like a light problem then a material problem. Set your light up next to the camera turn the spec down on your material and see what it looks like. Change the background to some thing more neutral. When you change one setting render, at this stage of test it will render fast and you will learn what the settings do. Make a bright pink or yellow texture and see what it looks like with different material settings and lighting. Try colored lights also but if you want realistic keep it mild. Another thing to try is add some more lights try a 3-point light set up(search for it) its good to show of a model but not much else other than learning some lighting. Keep us posted as this is a common problem especially if you are trying to get a white material.

Edit-- I cant tell for sure but that mesh you show looks like it may have some inverted normals try the texture on a suzane to see how it looks.

Thanks all, I got alot to work on. I’ll keep you posted.


There are a number of things that affect the perceived colour of an object.

  1. the actual colour (local colour) of the object
  2. the colour of the light shining on it
  3. the colour of anything near or next to the object, including the world/background colour
  4. highlight and shadow areas
  5. angle to the source light (main light) and viewer
  6. reflections and specular highlights
  7. Ambient light
  8. lots more that don’t immediately come to mind…

In your case, the first thing I’d do is change your world colour from Blender’s default “Hideous Blue”. Make it white or off white if you want to assess the object colour better. Almost any colour next to that strong blue is going to be “off” - except maybe a bright yellow which would actually increase in intensity.

Make sure your source light is pure white (All RGB sliders at 1.000) and energy is turned up high enough (this is arbitrary and depends on distance, among other things).

Check too if you have a value set for Ambient light in your world material settings. If so, this will also affect your object colour since the Amb slider is set to 0.500 in the Shaders panel (it has no effect if AmbR/G/B is set to 0,0,0)