Combination of Mixamo Animation Causes Crossed Arms?

I have no idea why but when I try to combine Mixamo animations, my models arms becomes all weird!

I’ve been trying to follow the steps from this tutorial:

Everything looks fine when I import both the main fbx with my model and the other fbx without skin. However the second I use the other fbx action on the main armature, the arms get crossed.

Blender link here:

(Additionally, if anybody can let me know how to have the second mixamo animation to start at the position the last animation ended instead of blinking back to the main starting location , that would be great!)

1 Like

Ok…as far as the arms doing weird things…it is connected to the REST pose…even though you set the locations to rig these in Mixamo and you can export the rigged model with animation ( and it works fine) if you then select another animation ( plays fine in Mixamo) when you try to add it to the character that works it trashes the rotation of the arms…WHY I don’t understand, but it is because the character was not in a T-Pose, to begin with. Even when you add a T-Pose to the Daz Character and export…the A-Pose is still the Rest Pose…as yet the only way around it I have found is to download with skins ( you still can’t add that animation to another )
I have even tried to save the T-Pose as the rest pose (Ctrl+A in Pose Mode) but it just doesn’t work.

Now the textures…the ones that are not working correctly is because they have not been connected to the named parts of the mesh…if in edit mode you select the lips that texture is connected to the whole face…the arms are not connected to anything…
Probably has something to do with the export out of Daz…FBX?

I use the Diffeomorphic Plugin and it works GREAT as long as it is set up correctly

Ahh seeing the angle the shoulders are warped, it being connected to the rest pose does make a lot of sense. There not being a fix for it is definitely frustrating though!! Given how many people use DAZ models with mixamo I’m surprised how this is not a more common issue, you’re the first person to give a logical explanation!

As with textures, before I upload it to mixamo, everything is working great though!

I am in the process of trying a new way of getting this done…
I saw that you had grabbed the T-Pose from Mixamo (GOOD)

Select your armature and go in “Pose Mode”.
Pose your object in the T-pose.
Go in “Object Mode” and select your deformed object.
In the object’s “Object Modifiers” stack, copy the “Armature Modifier” by pressing the “Copy” button. …
Apply the first “Armature Modifier” (the top one), but keep the bottom one.
Delete the Armature in 3d view or the collection !
You might need to resize and rotate your object ( I did ) then Ctrl+A and apply all.
Re-Export your FBX…and back to Mixamo…I am at that point right now…will let you know if it works correctly!!

Follow to next post>>>>

From my last post…Just uploaded and rigged t-pose mesh that I talked about! Downloaded with Catwalk anim with skin…add Ninja-run anim and downloaded with out skin…
Imported Catwalk FBX to Blender…
Imported Ninja…
In Object mode selected Catwalk Amature…went to Action Editor and selected the Ninja Run Action…SUCCESS!!!

Forgot…once you get all this done and have several Actions that now will work…in the Action Editor…select one of the actions and then press “Push Down” it will vanish ( It is OK) do all the actions you wish to use…
then go to the NLA editor…and you will see your actions…
if you Left Click on the action and drag to right it will turn Purple and you can now drag it to the Right and will be able to set it to start after another Action…

Awesome! I’m at the copy armature modifier step now. Is it normal for the model to look this terrifying? Hahaha

(also i noticed my model’s top half is a little off symmetry. Is there an easy fix for this or do I slowly try and centralise her in edit mode/sculpt mode?)

YES…That is what it will look like…Apply the TOP Modifier…Keep the Bottom one…

If you selected Mirror in Mixamo…no problem…if not still no Problem…that slight bit of symmetry won’t be a problem…

Hmm when I upload the scary tpose, mixamo doesnt ask for the rigging points and is basically stuck on this page, can’t seem to get past this stage!

SORRY!!! …I missed adding a step in my explanation…
After you Apply the first “Armature Modifier” above…Delete the armature from the 3d view / or from the outliner!!!
Make sure that everything is Joined BEFORE you Resize and Rotate…!!!

I really need to do a video on this…it is Convoluted but not Hard…better to watch someone do it all the way from Daz to Miximo to Blender!!

Your Mesh is really messed up….I would re-export from Daz…and start over…and perhaps you can get the textures assigned this time…it looks like the hand bones are just not working with the fingers…and the symmetry was just enough to mess things up…Looked like some diabolical creature with knives for fingers when I tried…Part of the Problem as I just re-loaded your character is scale was not applied…( That will have disastrous results !! )…

I just exported a Daz G8 figure, into Blender and deleted the armature from Daz, save to FBX, and imported into Mixamo…re-rigged and added a Ninja Run with Skin, a Catwalk without skin as well as a T-Pose without skin…and then did the above ( I will edit the original to add the missed step)…and it worked Perfectly…no weird stuff…the Arms in the air is OK and when you check the Rest-Pose it is Now the T-Pose…when you delete the armature …character will flop on its back and get very large ( scale and rotate, apply) but remain in the T-Pose…then carefully re-Rigg on Mixamo, add animation and export…then add animations you want and export without skin!!!

Oh man ok.
I mean, thank you so much for everything! But haha yeah I really like this model so this makes me sad haha.

Try and either just re-export from Daz ( need to fix the non-symmetry… don’t embed the textures but place them in a directory instead…embedded tends to not work well…if for some reason you can’t do that…then take the original FBX from Daz and make sure to Apply Scale or just all transforms…especially after deleting the armature Miximo doesn’t like outside armatures…re-export as FBX and then back to Mixamo…and do the steps in previous post…

I plan on getting some sort of tutorial made up for this as I struggled with it for a time and there is Nada on the web!!

BTW liked the Fashion run from the other post…cloth physics looked good…as far as the clipping…check on the cloth sim in both the cloth and collision and adjust object collision distances…Permeability / Stickiness etc…maybe even the weight of the cloth… I will usually run the Cloth-sim in the negative frames so that it is in full swing by frame one…and taking the walk cycle and duplicating and pasting reversed 100 frames at least and then I can select start and end from frames that look good and don’t have a problem as well as having the cycle flow smoothly!!
Happy Blending!!

Chiming into this, as I have been facing some of these problems myself, and also have some issues of my own.

I’m exporting a mesh with a rig, and it imports into mixamo automatically without having to set the points for the wrists etc. Your screen where it is stuck in mixamo could be related to having more than one rig in the scene when you export the FBX, at least it was for me - selecting ‘Selected only’ and only having the rig and the mesh selected fixed that.

Here’s my export settings:

Deselecting ‘Add Leaf Bones’ stops the extra bones being added to the end of the arms etc.

I unchecked ‘Bake animations’ as that was exporting all the animations from my blendfile into the .fbx, and they were coming back again when I exported from mixamo

Regarding the T pose - I found that if i exported with skin, the rest pose was the same as how I’d uploaded it (Almost T pose, kind of relaxed)


but if I export without the skin, the armature comes in with the rest pose as an absolute T pose:
. Seems like a bug over on the mixamo side.

Which would of course result in the rotation of the arm bones being different when animated.

The strange issue I’m now having, is that for some reason, my shoulder bones on my original rig aren’t being animated, even though they are named the same:

Can anyone have a look for me?

No_Shoulder_anim.blend (2.4 MB)

My original rig that I exported as an FBX and imported into mixamo is called ‘Original_Rig’, and then the rig that comes from the Mixamo export is called ‘Mixamo_Rig’