Compositing and Logos


I’m trying to figure out how to make something that could be described like a TV logo on a channel on T.V. I made the object parent to the camera so it follows it along, but I think that I need to put it on a different layer or something and composite them because I don’t want the scenery to reflect the logo or the defocus node to modify it. So once I’ve put the logo on a different layer, what do I do? I’ve tried some stuff with render layers and nodes, but I don’t really know what I’m doing, so I’m asking now. Any ideas?


You want to use the AlphaOver node to overlay the scene with the logo on top of the picture being broadcast. You can put the logo on a separate layer, and use RenderLayers to isolate and render only that layer (but it must be parented to the camera), or an entirely different scene with just the logo hanging there in front of a non-moving camera. Then use the Input node to bring it in. Either way, with A) two renderlayer nodes bringing in images from two different layer sets, or B) two renderlayer nodes bringing in images from two different scenes, they both get combined by the alphaover node.

If you dont want to use nodes, you can do B in the VSE as well, with Add->Scene, then shift clicking both strips and using the Add->Effect->AlphaOver.

I would suggest the B second way, where the logo is unto itself in a different scene, and the composite brings them together. You can even make the logo semi-transparent, with some alpha<1, for like a watermarking effect.

I’m probably going to stick to the nodes if I can figure it out. I’m not quite getting it yet so I’m going to attach an image of my render layers and node set up to see if I’m doing things right. The basic scene is on layer one, the logo on layer two. So if you check this out for me before I go any further, I would appreciate it.

Something to add onto here. When I try to get the render from the second layer, the logo isn’t showing up. Is this because the camera isn’t specifically on that layer or something?

Thanks again.


both scene layers 1 & 2 need to be selected. The renderlayer filters them out.

yes. a camera has to be on the layerset rendered.

I would feed the alpha from the logo renderlayer to the Fac input on the Alphaover node, to tell the node to use the top channel (the defocused image) when the logo is alpha 0, and the logo feed when the alpha is 1.

I kind of lost you on the last part. Why would I want to do it? Is it any better or something? I also didn’t see a setting to change the alpha and such. I think I have the compositing down now that I added another camera and changed some things in the render layer panel so thank you for that. Just need to figure out this other thing you mentioned now to see if it benefits me somehow, right now the nodes seem to be doing what I want them to so I dunno what it would be for.

Well, if it’s working the way you want, cool. There’s just many ways to skin a cat, that’s all.

Your current setup, the Fac is set at 1.0 which means that the node will use the alpha channel ONLY of the bottom socket in determining which channel to use. Which is fine in your case.

I’m bringing this back up again because now the camera isn’t working on the second layer properly. When I change the camera view in the first layer, it also does the same to the second layer. It’s like there’s some invisible camera that it’s using and I don’t want it to, I want to use the camera that I set up for the layer. So how do I set the camera on layer two to render with instead of the other one?

Any ideas?

you cant. There can be only one active rendering camera per scene at any one time. Otherwise, Blender wouldnt know which to render from when you press F12

So yeah, put the logo in another scene (real easy just in the SCE drop down Add New_>Full copy) and rename it to like LOGO, and set it up to shoot the logo. Then merge/overlay them using either nodes or VSE.

What node would I use to input them? Or would I have to export the animation then use nodes to put them together?

Use the RenderLayer nodes. The selector on the left chooses the scene, and the selector on the right chooses the RenderLayer within that scene.

Oh, I guess I missed seeing that. Thanks again.