Confusing Ray Mirror

Ok so I’m in the process of making a crown for an upcoming short. I threw on the velvet textures (which came out pretty nice if I do say so myself…and I do lol. But now I’m working on the gold. The issue is when I turn on ray mirror…it seems like the actual textures of the velvet are reflected off the gold. When I turn them off…it renders without them of course. I’d like to have a nice shiny gold material that WONT reflect the textures used on other things, but is still reflective…if that makes sense.

If none of that makes any sense check the screenshots and see the previews I made of them. Sorry I don’t know how t oshow you a picture of the full render…I’ve never needed to. So disregard the velvet material, which still looks good in the preview…but its better in the full render. The preview does however show my issue perfectly. The first screeny is without ray mirror turned on. The second is where its turned on to its fullest to emphasize my issue…it wont be that shiny in the finished product…but I would like SOME shine!!!

To avoid any possible confusion…there are no other objects besides the parts of the crown you see in the screen shots.

On testing I’ve noticed that no matter what angle I view this at…the only “prong” screwed up is the one you see in the previews as being screwed up. This is the one that I used to set up the array for the other “prongs” if that helps resolve my problem. Could it have something to do with that?
The third screen shot is the one with the whole crown rotated on the z axis…notice that there is still only one affected…and its the same one.


Mayne you have some inverted normals.

You can verify this by turning on “View Normals” from the Mesh Tools 1 panel in the Editing buttons (F9).

All normals should point outside.

To fix this, you can select the offending face (or all of them) and hit Ctrl-N.


No unfortunately that wasn’t it. It did help me find others though that I didn’t know about. So now I have 2 questions.

  1. What’s causing my issue?
  2. Why do some faces seem as if the normal is facing the right way, but when you find out its not and fix it, it looks like it should have looked prior to you actually finding out it was inverted?

I’m guessing you have overlapping double faces, perhaps you pressed duplicate or extrude and cancelled by accident or something. Try selecting all and doing remove doubles, or at least investigate to make sure the mesh really is only one poly thick.

I think maybe you have one too many arrayed objects, so that the last one overlaps the original mesh. Turn down the count by one, and see if that helps.

As for reflection, I think things will look much better if you just add and ‘environment’ to be reflected . . . even if the other parts of the crown are included. Add a World texture, and press Premul in the render settings if you only want it show in reflections but not in the background.

Can’t believe I didn’t get this for this one…I had to do it with the one facing opposite too. Attached you’ll find this fix is acceptable.

Yup, see above. You get thanks as well.

I’ve heard about this before but never really looked into it. I will now and post results later.