Construction Lines add-on - CAD - Released

Thanks Dave. I’m glad you got it working and thanks for the settings write-up. I’ve just updated the guide point scale limits to start from 0.0001 to see if that solves the guide scaling. I’ll send you a .zip for you to try if you like? If it works I can update for the 0.9.4 release.

I think Extrude Manifold is going to be a game-changer for SketchUp users, I’m currently working on making this work for primitives drawn in the center of faces, so we can cut holes in geometry just like in SU with Push/Pull.

Thanks for your comment. If you’re interested in trying the guide scale change can you PM me your email address and I’ll send a patch version through.

1 Like

Hi, Really ?? Extrude Manifolf it’s not very good i think, we can’t cut through.
I talk with howardt who develops the new boolean for 2.91 about that from what I understood he can do something later with extrude manifold or something else similar.
but if you found a way to do it that’s great :slight_smile:


1 Like

Hi, Love your addon! Would it be possible to get some more visual information for the construction lines, such as measurements that appear once you select a line?

2 Likes

Hi, thanks for the comment. Glad you’re getting on with Construction Lines. That’s a great idea on the guide lines, I’ll definitely try to implement that.

Extrude Manifold definitely needs a bit of work, especially with leaving some stray edges and not removing the final face when extruding to it but I think it’s a step in the right direction. A while ago, I did my own extrude that worked using booleans but since the developers changed how booleans work, it no longer functions properly (try overlapping two cubes and doing a difference boolean modifier). There’s been quite a few bug reports around the issues but they’ve yet to be addressed. I’m sure they’ll sort sometime though.
Extrude Manifold is very new though, so I’m hoping for some improvements in the next release of Blender.

HI, the future of extrude manifold should be this tool
https://developer.blender.org/T75913
otherwise overlap will be soon no longer an issue with new blender bolean (2.91 alpha) check that

1 Like

This is amazing

1 Like

can a support for drawing curves be added in the addon

1 Like

It’s on my list to look into. I’ll definitely investigate whether curves would work with CL and implement and implement if possible.

3 Likes

hint: Flexibezier addon

2 Likes

I had a major computer crash and had to reinstall everything. Contruction lines addon used to work , but now it doesn’t work on blender 2.83 or 2.90. Is there something I missed?

Is the Construction Lines iicon showing up in the tools? If so here’s a couple of things to try:

  1. Goto Window->Toggle System Console then try to run CL and see if any errors appear in the console
  2. Remove Construction Lines and re-install -> I’m sure you’ve tried this already but just in case
  3. Remove from the Blender Add-on directory yourself (usually C:\Users<User>\App Data\Roaming\Blender Foundation\Blender\2.90\scripts\addons) and then try to re-install

Let me know if any of these fix the issue. Was it Blender that caused your computer crash?

norrid, thank you for your help. I have tried the following:
Removed the addon and reinstalled it through preferences
Removed the addon and drop the folder my self and then enable it
Remove all the other addons from the folder and start blender

The icon shows up and is highlighted when I click on it but nothing happens, The console does not mention any errors with construction lines. My computer crash had nothing to do with blender. I had to reinstall windows and I only have about 5 programs installed at this moment. My son decided to over clock my cpu and graphics card. Could that be it?

I’m having the same issue as Ector3.
Blender 2.90.0, windows 10. It happens when I close blender and reopen again. The tool does nothing. It’s as is I could only use it on fresh new blend files.

Thanks @Ector3 for letting me know. I’m looking into this now and will come back with a solution as soon as I can.
@Spartako have you tried the suggestions I made to Ector3? Do you know what led to CL not working? It’s tough to fix this without being able to recreate the problem.

After I uninstall an addon I may hit save preferences and then refresh or just refresh and then reboot and re-install the addon again. I don’t know if it will help. Thanks

1 Like

Thanks, this is a good call. @Spartako @Ector3 this is worth trying as it may be not clearing things properly.
Also, can you try going to the Scripting Workspace and pasting bpy.ops.script.reload() into the console and hitting return. If any errors occur please let me know.

Yes, I tried all of those suggestions. Fresh install of blender (also tried version 2.82a), open a new file, install addon, play with it a little. Save the file and close blender. Open again, and its what Ector3 describes. Tried all the suggestions, to no avail. Uninstalled blender, tried again, same thing. If I open a new file, it works, then when I save it, close blender and reopen it, it doesn’t work anymore.

Spartako did you try an uninstall and immediately after, a refresh, then reboot blender and do a reinstall?Maybe don’t save preferences after you hit the uninstall button.

Bkjernisted, yes just tried that, same thing. Tried both saving and not saving prefs.

EDIT: also tried bpy.ops.script.reload() but still same result.