Convert 2.49 to 2.5

So I am completely lost. I am working on an animation of the earth spinning and trying to point a laser to certain spots on the earth for a work project. This is my first time working with blender and I don’t seem to “get it”. I have been trying suggestions that I found online and on this forum to no avail. It seems the problem is my animation was done in 2.49 which is COMPLETELY different from 2.5. I downloaded 2.5 and cannot get it to work. Someone on the forum suggested I ask for help converting my .blend file to 2.5, he didn’t think it would be hard at all for someone who knew what they were doing.

I am nervous to start from scratch because I REALLY don’t know what I am doing and most of the things I have gotten to work I stumbled upon by accident.

I cannot upload my .blend file to this forum, it seems to be too big. If you PM me I can email it to an email account.

Thank you

Try uploading to

Thanks Richard! I have uploaded it!

I would appreciate any help anyone can offer!

What exactly doesn’t work as you expect ?
You also haven’t included your textures in your blend so all there is of your planet is a grey sphere which is black in the render as the lamps inside the sphere

Richard, my textures are pretty big, two of them (the bluemarble and cloud files) are over 20 MB in size, the third which is just the site names is pretty small. I can email them if you would like.
When I try to move it to 2.5, nothing seems to work, it doesn’t animate, ie my earth doesn’t spin. I want to put it into 2.5 because I am having problems adding in my next step, a laser beam. I have tried a few things, but nothing has worked. Everyone that tries to help me cannot because they don’t work in 2.49, also some of the directions and explanations on how to do things don’t seem to work for me in 2.49, I am hoping that they work in 2.5!

there is nothing special about your file —
except, you may not know what you are using…?

The sphere is not a normal simple sphere.
If the animation is only rotating the sphere and
run a spot like a moon around it, its working.
But you should redo what you really want to do.

Try to write it down, so i can understand it.

If you have made the simulation,
then try to do the same in 2.5x - without any textures -
use only basic objects.
It should be easy to have a sphere rotating -
for example around the z-axis -
and it should be easy to add a a object (empty or spot-light)
to run around it in a circle.
If you can manage this, then it should be no problem to import
your old sphere-mesh with its large textures to replace the simple

can someone point out how to see the camera in viewport
i tried with alt-H but it is not hidden !

so how come we don’t see it ?

here are some basic intro to animation in 2.5

Animaton 2.5

intro to animation

this is a lot morempowerfull then in the old 2.5 and needs some times to get used to
but it is worth the effort


he has set the object-display-color (of the camera) to hide it
and he did set a marker and keyed its appearance for all layers.
After delete those camera-animations, the camera is on layer 6
(? first layer-block second row…) and set a visible color and zoom
closer to the camera (its really small because of the big-huge scene)
then the normal cage can be seen (you may select the camera in the
outliner and press numpad-/ to make it the only visible object …)

What’s wrong, it seems to work fine for me in 2.5x…