Convert path animation to keyframed

Hi guys,

I have created a follow path animation (using a nurbs) of an object and wanted to export as fbx to import in another software.

I have sucessfully exported keyframed animations through fbx that way but it seems path animations will not be exported. Maybe fbx doesn’t support this.

Is there a way to “convert” follow path animation to keyframed animations ?

Not really enough info here to provide a good answer…

I just created a curve path, parented the default cube to it, choosing the follow path option, and got the defualt cube following my path. I then baked the animation, choosing the ‘visual keying’ option, then deleted the path object. Now the default cube moves as it did when it was a child of the path because it is key framed. Simple and it works.

If this doesn’t work for you, you might want to provide more information. What type of object is following the path? Is it a simple object, like a baseball, or a more complex object like a rigged character/machine? How are you doing the path animation? Via parenting or follow path constraint? What is the end result? I get it that you are exporting fbx, but exporting to where? A game engine?


It‘s a simple object and I created just a constraint using a nurbs path. I want to import in Pangolin Beyond Lasershow Software which accepts only fbx for animations. I think your 2 last steps are what I‘m missing. „…baked the animation, choosing the ‘visual keying’ option,. But where in 2.8 can I find theese two options/menu entrys ? I tried the bake button in render menu but got an error message.

If you can’t find an operator, use the SPACE > search it’s name. In you’re case, it’s SPACE > Bake Action. By the way, the fbx exporter bakes animation by by default (Exporter Settings > Animation > Bake Animation). Set the Simplify factor to 0, if you want to avoid precision errors in your animation, the default value (1) is prone to cause them.

Thanks for your hints so far, I managed to bake it and the resulting fbx file now has the right numer of frames (instead of zero before) but the object is still not moving in my other application. Meanwhile I guess this is a compatility problem with fbx import of the software, not a blender issue.

Update: Strange: I tried a simple fbx viewer (Clockstone FBX Viewer) instead of my Lasershow Software and there I got an animation but it was incomplete in the sense of a missing z component of movement …

Finally I got it to work: In baking options I disabled “visual keying” and “Clear constraints”. Afterwards I created again some keyframes manually along the path and exported as fbx.The inported fbx file delivered expected results.