Could someone please tell me how to enable textures?

I’ve seen the demos with textures and stuff, but I can’t manage to enable them for myself… Help please? What do I press?

For renders or games?

Obviously since this is the GE forum Game Engine textures.

Whoa! OK, it’s just I usually browse forums via the ‘View new posts’ button rather than the actual forums themselves.

Do you mean the new features that were released with 2.41?

I believe Blender3d.org has a answer to your question…

It might but I can’t find where. I press add texture after assigning a material, I upload an image, and in the material preview it looks fine, but when I press “p” the texture isn’t shown!!! It works in the demos and stuff, why can’t I get it to work? Please don’t post crap like “You can find the answer if you look here.” Just frickin’ tell me.

Look in the console after you press P. It may say something like “GLSL not supported”. This is because like mine, your graphics card is too rubbish, and you won’t have any luck getting them to work!

I’m not sure what you mean but well I make this reply beginners proof. :wink:

Textures in game engine, enable them.
Ok let’s say we have a simple cube and want to add a texture to it. Select the cube, press F key to go into face slection mode. Now you’ll notice you can select each side of the cube, which means you’re selecting faces of that cube. Now in the another viewport open the texture window (shown as a face icon, a face of a girl I thought)
Now there are some buttons on the bottom of this screen, and you’ll find a button saying, ‘open image’. Now notice youhave selected your cube and load image and add that one.
Now you won’t see the texure appear on your cube yet, because you’re in shaded mode or whatever. Press ALT+Z and you see, yes a texture on your cube. :o :stuck_out_tongue:

2th, I want to render my mesh but it doesn’t show the texture.
Well it gies the same as above, select mesh add a texture image, but now come the trick. :slight_smile:
When you apply a material to the emsh and render it won’t show the texture. Now there is a button that tells you to enable textures for rendering. Press that and render. :slight_smile:

Notice the 1st explaination work in the game engine. The 2th explaination with the material and enabling textures for rendering is ment for the renderer, not the game engine.

I hope you could use this. Else try this.
http://www.tutorialized.com/tutorial/UV-Mapping-Texturing/5852
And search ont his page for Uv mapping and texturing.
http://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro#Beginner_Tutorials
That last link is usefull to learn blender. Next time try to google around. Blender has a huge amount of tutorials online, which are outdated or up to date, but still they are all compatible with the last version of blender. Still those technics work still the same way as they did in old versions, only in some cases it has been made easier then it was a 5 years ago. :smiley:

MY GOSH, PEOPLE! NOT UV TEXTURING! TEXTURING AS IN MATERIAL TEXTURING! AS IN THE FREAKING NEW TEXTURING IN THE NEW FREAKING VERSION! IF YOU STILL CAN’T UNDERSTAND, I MEAN THE KIND OF TEXTURES WHERE YOU CAN ONLY USE ENV MAPS AND IMAGES!!!

Am I clear? I’m talking about using blender 2.41 brand new textures.

Edit: You can tell I’m angry, but don’t take it too personally.

Further Edit: I can see why I confused people. Anyway, the textures I wanted are the textures under (shading)-(texture buttons). Just to be perfectly clear. Thanks for trying to help, but I guess no one knew what I was talking about.

LAST EDIT: I figured it out, never mind!

Whoow, relax. If you post like that nobody is going to help you.
I missunderstood you, but well if you had told about the new feature to use, then I would have answered different.
Personally I don’t know how to do it myself yet, since I’m not really familiar with these new things.
Anyways I have a link here to the blender website that contains some little code that shows you how to enable it. I hope that helps. http://www.blender3d.org/cms/Blender_2_41.731.0.html

But next time don’t post in caps, I could have said MAN GOOGLE THE FREAKING WEB. :wink: But I didn’t

Blender-rox - select from the Game drop down menu at the top of Blenders UI - select the option “Use Materials” something or other… Hope this helps. If this dosen’t help then your graphics card dosen’t support these shaders.