Crashes While Rendering Animation with Yafray

Using Yafray in Blender to render an animation with fluids, individual frames render fine with F12, but when I try to render the short animation, Blender crashes with the Microsoft Visual C++ Runtime Library dialog box giving a runtime error abnormal program termination message. No helpful diagnostics in the console: it seems to be part way through building the kd-tree then just stops. I tried to work round this by rendering to a series of jpeg images rather than an avi, but no luck: after about 17 frames it’ll crash. The frames that have been rendered are fine, and I can restart the animation at the next frame and it’ll do another few before crashing again, but this obviously isn’t a long-term solution. All advice would be very welcome.

u should try to append it (shift f1) (might be alt f1) to a default blender scene, then render it, might fix yo problem

OK I’ll give it a go, thanks. Would you re-bake the fluid, or use the old bake files?

Well, I gave it a try but no joy unfortunately. Anyone know why this happens? I would assume that if Blender can render one image it can render a sequence of images to disk as it’s simply repeating an operation many times: it doesn’t have to accumulate anything in memory etc. Or is this hopelessly naive? Or are there maybe any scripts out there which would provide a workaround? Very frustrating having an animation I can render as individual frames but not as a complete sequence…

what version of blender and yafray are you using?

Blender 2.45, Yafray 0.0.9, Windows XP.

Sorry to be the version maniac, but is XP SP2, and are your video drivers up to date?
also, what resolution is your fluid baked at, and how much RAM does your computer have?

No problem: yes, XP Pro SP2, video drivers updated, 1G RAM, 1.7GHz processor. I’ve tried it on a range of machines with up to 2G RAM, but always the same problem. Fliuds are baked at a resolution of only 64: any higher than this and the images won’t render at all, but at 64 each image renders OK.

View this thread
The problem discribed there looks as if its the same.

Many thanks for the suggestion, though I think my problem’s slightly different: I can render the fluid (resolution 64, subdiv 2) as a single image anywhere in the animation, I just can’t get it to render a sequence of such images without crashing!