Crescent Dawn Alpha 2: Downloads moved (linux, windows), Server online (no dialup)

The test has now officially begun. You can start breaking real stuff now.

Windows - 12 mb rar
If you have downloaded the client previously, this is a brand new version and you shouldn’t overwrite any old files.

If you get a gray screen when you run any of the cdo.bat files, please post the contents of dat/stderr and I will do my best to figure out why it’s not working.

Linux - 13 mb .tar.bz2
Run “cdo” which is the main executable file.
If you get errors it could be because pygame isn’t liking your sound card. Open settings.ini and under the [client] section, set musicvolume=0 and soundvolume=0.

Server is: Offline

i have to admit guys, saluk has been the trooper in this round. He has been working his butt off and if I had worked as hard as him the game would be looking a lot better. I apologize. I hope you guys like my music, sfx, and temporary graphics :slight_smile:

get it while you can!


I got some errors:

Can’t find:


Windows blocked packetfilter.exe

My cisco firewall closed down port 6361.

The game loads in the end and I can see the log on screen.
Is there anything I need to do here, or will it all still work?

PS: What is your definition of a good cpu? >2Ghz?

i have the same con’t find errors but i dont have any problem with my firewall i just click allow nice so far with the animations and stuff but i think you should make the cursor move faster

congrats on the release fellas :slight_smile: will see you in-game i hope

sweet work!

what IS your defenition of a fast cpu? :stuck_out_tongue:

@scabootssca: use periods.


well 1.2ghz laptop had issues with it, but my a64 3000+ desktop worked fine…

just is a warning in case it doesnt work.

About the build ill talk to saluk and see what we can do :slight_smile:


maybe I’ll have saluk add a fader to adjust that.

It works fine for me! Now get the server online, who cares about other people downloading! :wink:

Ok why do i get the error when i try and run the Dos batch file
“Another program is curentlly useing this program”

i’ve got the same errors as social

is that cause i have python 24 and not 23?

and what is the smpeg.dll??, i haven’t got that

Can someone pleas give the reasons for that, cause i really want to play this game!

I have Python 2.4, and it works fine, so I don’t believe that’s the problem (though I do have 2.3 as well). I only get a message about smpeg.dll when I close the program, though.

i left a msg with saluk about this, im getting the error too. sorry, im sure he’ll fix it asap, its nothing big.


I did a quick google search for smpeg, and its a free download (cant remember link, just google it). Its also Open Source, so you guys should be able to add it to the CDO distribution without any worries.

@Saluk, I have a server if you’d like me to host the setup file, distract some bandwidth from your test server? Just say the word and I can upload the build linked in this thread straight away.

EDIT: PS. I’ll do a direct link, dont worry I’m not trying some pay-per-click scam here, just want to help you guys get this project going any way I can! :slight_smile:

Those errors probably won’t affect the game working, it’s just a few of the dependancies that for some reason need dlls even when you don’t use the features in them :confused: I provided a patch file in the top post for everyone who downloaded the error version, so please download it. I also updated the main zip, so if you haven’t downloaded the game yet, you can get the full download and not worry about the patch. I also have provided the linux version to download, it will definately require python to be installed, but shouldn’t need the other dependancies.

MeiaLua: I wouldn’t mind at all if you could mirror the links, I actually was going to ask people to mirror them today. I was also planning on putting up a torrent a little later, if anyone wants to beat me to it be my guest. Make sure that if you do host a mirror or put up a torrent, you use this latest archive rather than the one I posted last night that had the errors.

EDIT: Here they be:

Mirrored new builds as of 19 March 06


Thank you MeiaLua!

My hope is to get the server finished and updated by the end of the day, so everyone can play :slight_smile:

braveheart - are you running windows xp? I haven’t tested on any other versions of windows besides xp, and I expect there will be problems. Either way, see if it works now with the updated archive.

I’m getting a ‘server could not be reached’ error. I told windows firewall to allow it, though…

it’s because the server is not up yet chack back in 1-2 days