CUDA broken on linux (ubuntu) with latest drivers ?


At the moment CUDA seems totally broken on my system (ubuntu x64 12.04, GTX 570 on dual-screen).

Cycles was working perfectly fine until a few weeks ago, then after a ‘casual’ update, it stopped working for some reason, alongside with Octane and Indigo (who both use CUDA).

So when I launch blender and start a GPU render with Cycles, I get this error message.

CUDA error: Unknown error
CUDA error: Invalid context in cuMemAlloc(&device_pointer, mem.memory_size())
Abandon (core dumped)

It’s the same with 2.62, 2.63 and 2.63 SVN.

Suspecting that the latest Nvidia’s drivers (295.40) might be the cause of the problem, I reverted manually to previous version 295.33, but it didn’t fix anything.
I even tried latest beta 302.07.

So, if the drivers aren’t causing the problem, what might be ? I bet I’m not the only one encountering this problem.

Any help much appreciated !

I had similar problems with cuda and ubuntu11.04 by just doing a regular update, apparently ubuntu’s drivers for nvidia proprietory or otherwise are trimmed/tweaked to ubuntu’s liking. If you want a quick fix you could try loading a previous kernel version for linux from the ‘bootloader’ this worked for me.

Hope this helps

Thanks, I will try that

Well, I installed and booted 3.1.10 : nothing improved.
Which one is to blame : the kernel or nvidia’s driver ? I’m quite clueless.

i know that when installing Octane, it required that i install the CUDA SDK and toolkit and all that jazz; it seemed like that actually required kernel 2.6.x… i couldn’t even install either the SDK or the toolkit (i forget now which one it was that i had the problem with) in Ubuntu 11.10, it gave me an error message and forced me to quit the installation. i had to revert to 11.04 (which i actually like better anyway). if you’re using 3.1.10, that sounds like you’re using 11.10 or higher?

edit: sorry, i just reread and saw that you said you’re using 12.04. strange - you had Octane working in 12.04?

I think Octane stopped working alongside with cycles and indigo, just before I switched to 12.04.
For Octane to work, you just need the toolkit (not the SDK), and I can install it fine on 12.04.
Anyway, my last clue is to try the combination kernel 3.1.10 + nvidia 295.33, if that doesn’t work I’ll open a new bug report for ubuntu, something’s very fishy here !