CUDA rendering, no GPU usage in task manager

Hello there,
I tried to enable cuda rendering to render on my 1060 ti, cuz it should be faster, the thing is I’m not sure if it is really using my GPU, because, when the CPU is active, task mnager showes you that blender is using 80% of the CPU, but it barely reaches 10% of my GPU,
Isn’t supposed for the rendering to be little more GPU intensive since I enabled CUDA, or there is something I missed in my preferences

This question has been asked by many people including me.
Change the "3D’ to “Cuda” in GPU panel and you will see the GPU load.