Cursor location not where expected

This is not working as it seems it should.

I’m trying to create a shape key to correct a problem with the mesh.
Options on the armature modifier include: Render, Realtime, Edit Mode, and On Cage

I want to move a loop - specifically, I want to rotate it around a central axis, like the cursor. I select the loop, select to move the cursor to selected, and the cursor moves to where the vertices would be were the armature in Rest Pose. This causes some interesting problems.

Placing the cursor with the mouse leaves the cursor on the outside of the figure. I can’t seem to place the cursor anywhere near where I want it.

Is there a way to locate the cursor to the middle of the selected vertices?

I don’t have much knowledge about armatures and posing, but there is a hacky way to do this:

Duplicate the mesh you are working on, apply the armature modifier, enter edit mode, select the loop, position the cursor, exit edit mode, delete the duplicated mesh.

Select the loop and hit shift+s, “cursor to selected”

That’s what I did. The cursor ends up some distance away from the selected vertices.

Interesting, but it doesn’t seem to do anything different. Shift+S, “cursor to selected” still puts the cursor in the wrong place.

Are you sure you were in the copied mesh, which had the applied deformation applied? And you were in edit mode, not in object mode? Because I tested the method I suggested, and it worked.

I’ll try again. but the copied mesh was already linked to the armature and when I selected a loop & chose “cursor to selected”, it did the same thing:

Selected loop is on the upper arm, cursor positions above the raised hand - approximately where the selected vertices would be if the armature was in “rest” position.

When I meant to apply the armature to the copy, I meant to got to the modifiers stack, and click apply (this removes the armature modifier, and applies the transformations). So the copied mesh shouldn’t have an armature, it’s geometry and pose is baked, after this, you can position the cursor.

I think this is a bug, possibly related to:
Hopefully it will be fixed in the future, and will not require such workarounds.

Ah yes I didn’t read that correctly. Meshes generated or deformed by modifiers (such as armature) cannot all be viewed reliably in edit mode, so what’s really happening is Blender only uses the undeformed vertices when you try to snap your cursor to them. What you can simply do is use the cursor tool, choose “volume” snapping type and click the arm from the side, you should end up with a usable cursor placement.

My error.

I made a new copy, went to the modifier stack & selected “Apply”
I got an error message, “Modifier cannot be applied to a mesh with a shape key”.
Since I already have several shape keys on the mesh, I don’t think this hack will work. I will keep it in mind for future instances though.


Sadly, it doesn’t seem to be working.

I selected volume, shift+s, cursor to selected. Cursor stayed where it was, at the “rest” location.
I tried the 4 options: Closest, Center, Median, and Active. The cursor doesn’t move.


If it makes any difference, I’m using Blender 2.82a on Fedora 32


Use cursor tool and click

I’m sorry. I don’t understand.
I make a selection on this menu.
Press Shift+S, “cursor to selected”.
The cursor moves to (or stays) at the “wrong” location

That part is correct, but then, don’t use “snap cursor to selected” operator, rather use the cursor tool directly and click on the mesh to place it

okay. I think I’ve got it. I also had to turn off “Surface Project” before it worked.


Hm, can you try the following: select the copied mesh, and click Object / Convert to / Mesh from …

I have not tried with armature, but with shape keys + subsurf modifier (this was simpler to set up), and was able to transform a modifier with shape keys to concrete geometry.


I’ll try it out.