Curve Modifier After Array Leaves Gaps?

Hi All,

I am trying to make a bendable sci-fi hallway. I have a single section of the hallway done. I added an array modifier to each part and set the constant offset for each part. This all looks fine, I have a hallway that can go on for as many array duplicates I want.

Next, I add the curve modifier to each element in the hallway section. Each element uses the same curve. However, I now have gaps in my curved based hallway.

Is there anyway to fix this?:frowning:

I have tried setting all the control points on the curve to vector and automatic, no change there.



Perhaps a relative offset of 1.0 and hit Merge?

If this fails please post .blend file and we can take a look.

Kindest Regards,


I managed to fix it by joining all the meshes together and using only a single array and curve modifier.


I would have used a Group rather than join the meshes.

apply the array before hand or increase the array count of offset

@secondar: You can’t use a group with an array, it only works with a single mesh. But that was my fist thought too! I created a plane removed all but a single vertex, then dupli gouped my objects. I applied the array modifier and nothing! It looks like dupli group is applied after modifiers take place internally.

@brados33: I tried relative offsetting and absolute, neither one worked.

It actually looks OK until I apply the curve, that is when it breaks.

Anyway, I am happy with my joining solution. I would have preffered to keep all the obbjecs sperate, but they do each have their own material ID so I can sill manipulate them as I need.