Custom Shape for Bone - Not Shaded?

For some reason my main control bone on this rig looks strange when I apply a custom shape. It shows up as a wireframe even though other custom shapes are shaded.

The custom shape was created by a extruding a circle mesh. If I use a normal primitive, it looks shaded. But this custom mesh stays in wireframe. Any ideas why?

The mesh is on a separate display layer

Here is my blender file for anyone interested…


Stormtrooper_rig_BIND_start5.blend (867 KB)

It draws as solid for me as soon as I open the file. In the bone panel for that go to display and see if you have wireframe checked.

Thanks for the feedback DruBan… I’m wondering if it is my graphics card. When I do have wireframe checked, I see just the outlines, no separations between faces.

I hope and think it’s not your graphics card. check normals in original shape are pointing in the direction you want. Check drawing is GLSL. Check if the original shape itself is drawn properly in 3D view. Does it have a material assigned. Check to see if scales have been applied. Check to see if there are doubled verts.
See if this file works?

Hi DruBan - thanks! Yes in your file, the circle shape is shaded. But you extruded it one axis further, giving it some volume…
Another strange thing: in your file when I go to display layer 2 and select the meshes in shaded view, they do not have an orange outline like I am used to…

I have the ‘outline selected’ turned off in my ui. You have load ui checked in yr prefs. Just for fun, uncheck it and then open my file again to see if it’s something in your UI causing this.

The missing orange outline was definitely because you had “outline selected” turned off. I unchecked “load Ui” in my prefs but didn’t have any impact on anything…

Still cant figure out the initial problem of a non-shaded extruded circle!!! >.<

thanks for responding though!