"Cut Loop", ctrl+r: getting more cuts/ scroll wheel not increasing cut #

When watching this tutorial:

The instructor uses the scroll wheel to increase the # of cuts. ( ~6:22) He’s using 2.78.5 though.

When I use the scroll wheel, it zooms the viewport. Now, I suspect this is highly sensitive to the exact order, and when you are holding down the LMB. (EG, WHILE you are holding it down, immediately AFTER you click it, etc) But I don’t know if this wheel feature is still in 2.8, so could somebody confirm it’s still there, and the timing one needs to use it if it is.

THANKS!

it works just ctrl+r then move your cursor so the yellow line is where you want to add your loops then scroll to add the right amount of loops then you click left mouse button they turn orange and you can’t add any more loops…

when orange you can adjust the where they are in that area then you left click again to confirm. if they already exactly where you want them then you click right away to confirm.

summary ctrl+r to start operation (yellow lines) scroll mouse wheel to add loop cuts -->left click mouse button to confirm the amount of loops lines turns orange --> fine tune placement or just click left mouse button to finish.

Thank you for your help. Unfortunately, in my installation of 2.8/W10, at ANY step scrolling the mouse wheel zooms the viewport rather than changing the # of cut lines. :sob: :sob:

Now, the # of lines remain interactive thru the F9 panel slider (but not the “n” panel, why is that?) so it is adjustable up until the next operation beings, which I guess is good, but certainly not as convenient as having them “in” the scroll wheel.

I’ll continue to try to get the order and sequence right --at least now I know it is possible. Could you tell me what OS & version you are running under?

Thanks again, appreciated. :+1:

You can use the Page Up and Page Down keys as an alternative to mousewheel-controlled actions.

1 Like

I have the official 2.80 version and windows 10. A long shot could be to go into file (in top row to the left)—> defaults and load factory settings.

f9 and n-panel works for me as well

hope you find the solution :slight_smile:

Thank you both for your help and oOErikOo for his perseverance. :+1:

There’s , fwiw, more hints in that PAGE UP/DOWN are having no effect also. :sob:

I think I’ll first try the DEFAULTS/FACTORY SETTINGS reset (I haven’t altered, tmk, anything in the preferences, specifically the keymaps), and then perhaps do a re-install.

Thanks for being good community members and helping the n0oB. :upside_down_face:

1 Like

See the 2 minute mark of this video. It might help. https://www.youtube.com/watch?v=-pCf3DjsEBg&list=PLa1F2ddGya_-UvuAqHAksYnB0qL9yWDO6&index=13

bkjernisted, BINGO!!! That’s the secret sauce here: the loop cut TOOL can’t be Selected for the scroll wheel increment/decrement to work!

-Gosh, I’m not sure that’s such a good UI decision, to have different UI mechanics for when you are hotkeying the tool versus when you’ve selected the tool from the tool bar: philosophically and practically that just seems a needless and confusing (obviously, to me) difference. But , I’ll take that up with the devs.

:+1: Thanks to everybody for sticking with me! Much appreciated, and hopefully I’ll have a chance to return the favor down the line. :innocent: :nerd_face:

2 Likes

This is mainly to do with the differences between how “tools” traditionally work in blender versus how they work in other apps. For 2.8, they wanted the tools in the toolbar to work more like how they would in other programs, but that way of working isn’t compatible with how the commands worked in blender before, so changes had to be made to their active tool counter parts. They can’t simply remove the older command versions of tools either because they are faster, and for most people they are the only reason to choose blender for modeling over other options.

You might want to try the “industry compatible” keymap that comes shipped with 2.8 instead. With that keymap all the shortcuts evoke toolbar tools instead of the traditional commands for operations, so things are more consistent, but there is the downside of not being able to use most of the tutorials available for 2.8.

That seems like a very silly motivation. How many apps even have “Loop Cut”, like 8?

I’d rather have hotkey and icon tools behave consistently within the app I’m using.

I recommend that you try 2.79 before saying this (no need to install, just download the zip version). Their choice for 2.8 will make a lot more sense once you see how the toolbar tools worked back then. The loopcut and knife tools work well enough as part of that toolbar, but the concept breaks down for stuff like scale and rotate (cursor needs to be near the target to work well). The spin tool also works a lot better as an active tool than it did as a command.

Lets say I want to cut 6 loops into one face. I’d find the ctrl + r version of loopcut better for this since I don’t need to switch from my current active tool and can set the number of cuts with the mouse wheel. However, if i need to cut 3 loops into 8 different faces in a row I would need to press ctrl + r 8 times as well as repeatedly scroll my mouse wheel to set 3 loops to do this. There used to be an addon just for situations where you needed to repeat this type of action. Its active tool version on the other hand just requires me to set the number of cuts to 3, then click on each face that needs to be cut.

It’s true that a lot of the new tools are redundant when you use the commands, but there are still cases like this where your workflow is improved by using these alongside their command versions.

1 Like