CVS Checkout Orange Branch

High everyone,
is it possible to CVS checkout the orange branch? And how would I do this? (familiar with “normal” CVS and compiling but dont know how to switch to another branch…)
Thanx in advance

If you’re using linux and already have a checkout of the main cvs, you can update it to the orange branch by using this command:

cvs -z3 update -APd -r orange

If you want a fresh checkout, do:

cvs -d:pserver:[email protected]:/cvsroot/bf-blender login

cvs -z3 -d:pserver:[email protected]:/cvsroot/bf-blender co blender -r orange

thanx alot! (gonna be fun to see that in action today… :D)

I’m interested in this too but when I tried to do a full checkout I got the following:

cvs server: cannot find module `-r' - ignored
cvs server: cannot find module `orange' - ignored
cvs [checkout aborted]: cannot expand modules

I just used your commands from above… did I miss something?

Oops, I forgot the tag order was different when doing a fresh checkout. It should be:

cvs -z3 -d:pserver:[email protected]:/cvsroot/bf-blender co -r orange blender 

me again. i’ve been working like crazy so i just now found time to try the orange branch. i checkout both bf-blender and orange today, used the same sConstruct and config-opts. bf-blender compiles, but orange doesnt. and i’m not very good at reading the stuff the compiler spits out, so here it is:

g++ -pipe -funsigned-char -O2 -Wall -W -DGAMEBLENDER=0 -DNDEBUG -I/mnt/04_shared_resources/BlenderCVS/build/linux2/source/ke rnel/gen_messaging -Isource/kernel/gen_messaging -Isource/kernel/gen_messaging -I/mnt/04_shared_resources/BlenderCVS/build/l inux2/source/kernel/gen_system -Isource/kernel/gen_system -Isource/kernel/gen_system -Iintern/string -Iintern/moto/include - c -o /mnt/04_shared_resources/BlenderCVS/build/linux2/source/kernel/gen_system/GEN_HashedPtr.o source/kernel/gen_system/GEN_ HashedPtr.cpp
source/kernel/gen_system/GEN_HashedPtr.h: In member function »unsigned int GEN_HashedPtr::hash() const«:
source/kernel/gen_system/GEN_HashedPtr.h:43: Fehler: Typumwandlung von »void*« nach »unsigned int« verliert Genauigkeit
scons: *** [/mnt/04_shared_resources/BlenderCVS/build/linux2/source/kernel/gen_system/GEN_HashedPtr.o] Error 1
scons: building terminated because of errors.

What could be the reason for this (again, bf-blender compiles without complains…)
thanx in advance

back from holiday, so happy new year, everyone,

but back to (fun-)business…
still no luck to compile orange on 64bit linux. Error ist still the same than previous post. So I am begging for suggestions on how to master this problem…

otherwise i might have to wait till stuff gets into regular CVS (which comilies, no problem). make me a happy man and tell me what i did wrong…:slight_smile: