Cycle render problem

So, I recently got Blender 2.71, and being new to the whole 3D modelling thing, I was following along with some of the tutorials. Eventually I got to one dealing with cycle render, but when I select cycle render the 3D view port turns pink and I cant see anything in the 3D view. Is there any way to fix this?
I added a picture just to show you what is happening when I select cycle render.

EDIT: I should also mention that it is only pink in the rendered view. In wireframe, solid view and the others, it works fine.


Chances are that the environment and objects are textured and you are missing those textures. Cycles “highlights” such objects in magenta. You can either disconnect the texture nodes, find the textures the scene was loaded with, or replace them with your own.

That being said, I could not see your attachment because of a bug in the forum…

I don’t think that would be it, because I didn’t have any textures… it was just a plain square from when you boot up blender, and it was the whole 3D view port… as for the image I posted, do I have to repost it?

You’re going to need to provide more details:

  • What operating system are you using?
  • What type of CPU do you have?
  • What type of video card do you have?
  • Are you using the 32-bit or 64-bit version of Blender?
  • Does the pink show up just in rendered view, or is it in textured view, material view, and wireframe view, too?

-I am using Windows 7 Home premium
-I have a Compaq Presario notebook with an AMD Athlon II Dual-Core processor 2.10 GHz
-AMD M880G with ATI Mobility Radeon HD 4200
-I am using the 64-bit
-It only shows up in the rendered view of cycles render. If I am in Blender Render, then the rendered view works fine

Step 1 - File / External Data / Pack All into Blend
Step 2 - Save your file
Step 3 - Upload blend file to http://www.pasteall.org/blend/
Step 4 - When upload complete copy and paste the download site link into a post here


Change any window to Node Editor and choose World nodes. Make sure they look like in image and there is no Image Texture node.
You can even uncheck Use Nodes.

I went to node editor and chose world nodes like you said, but their is no default nodes like in your image. Could that be the problem? and if so, how do I fix it?

EDIT: Nevermind, I saw that default nodes was unchecked and I got them to appear, just like in your image, but there is no change. I still get the pink screen.

http://www.pasteall.org/blend/30492

here is the link.

The file is just the default cube ! This is not the same file as the screenshot in the first post

That’s the problem though. even the default cube does the same thing. I start up blender, select cycle render, click rendered view, and I get the pink screen, like in my screenshot. Yet it works fine in blender render, with rendered view.

File is perfectly gray here in rendered view, cycles. Could be something to do either with your user preferences file or blender installation.
From where Blender installation came from?
Hope you have Cycles in CPU mode, not anything like OpenCL or whatever can be set on User Prefs -System and Render tab for your GPU?
What if you try File - Load Factory settings?

Edit: yeah… looks same like above mentioned.

What happens when you render the scene (F12) ? Does it shows up as pink too?
Can you screenshot the parameters in the Render tab?

Same gray cube in rendered mode, standard CPU rendering.

What is reported driver version/make for you right now?
This can be checked in the device manager under the Display Adapters.

Have you tried to set up new drivers for your video card? http://support.amd.com/en-us/download/desktop?os=Windows+7+-+64#amd-catalyst-packages

If this does not work or install here is what they call “Legacy” stuff
http://support.amd.com/en-us/download/desktop/legacy?product=legacy2&os=Windows%207%20-%2064

So updating the drivers did solve the issue. Thanks for all your help! I really appreciate it!