Cycles baking returns white image

I’ve got this simple material, made with 3 image textures

when I hit “Bake” (the settings are shown in the following image and the Image Texture node containing the destionation image is selected, as shown in the first image)

the result is a white image, as shown in the following image:

Could someone help me to understand why this happens? I tried to change the destination Image Texture node from “Generated” to “Single Image” and load a blank image, but the result is the same.

Thank you!

First i wonder why you posted this in BA Website Support ?
Anyway: why did you scaled the UV’ s by 200 ?? Using the standard cube with the standard color grid A-H/1-8 will resut into this :

1 Like

Thank you for the answer.
Sorry, it was late at night and I was sleepy :smiley:

However I scaled it to 200 because the skin texture is very small and I had to scale it to have a realistic result. I had the same doubt, so I tried to reset it to 1 and bake again, just to try. The problem remains, so is not a matter of scale.

A couple of things I noticed while trying this out. The normal map will not have an effect if you are only baking color (I think). Is that possibly a screengrab of the alpha channel of the image?

I don’t think so, the configuration in the baking section is set to bake the Diffuse map, taking only the Color (no direct or indirect), so it should not consider the Alpha channel at all

Unfortunately I wasn’t clear. I meant maybe you had set the image viewer to display alpha and you were looking at that. It was just a guess.



If its still a problem I can try to take a look a the file, If they are large image textures, maybe you can put it all in a zip. Or pack and use we transfer or something similar.

Ah, my bad, I didn’t understand what you meant.
However, the Image Viewer was regularly set on Color and Alpha, so it’s not that.
I took a better look at the baked image and noticed that the image is not really white, but it’s more like very bright. If you zoom the image, you can notice that there are some details of the texture (the texture to be baked is human skin).
Below is a zoomed image showing the (very hard to see) details.

Just a thought do you have any colour management settings that are brightening the image?

1 Like

Hi Pietro,

trying turning the Subsurface value down to zero ( it’s at 0.095 in your shader ) then bake the diffuse. That tiny amount of subSurface is enough to blow-out your colour because it is already very light.



Indeed, that may be it. The other day, I got a similar issue when baking with sss enabled. I think there may be a bug here, because my diffuse texture got brightened by a huge amount just by using a tiny bit of sss.

1 Like

Yeah, it looks splotchy yellow.

Yep, it was it!

I turned down the Subsurface to 0, as suggested by DamianJ and now the baking is perfect.

Thank you!

1 Like