[Cycles] Black geometry on 100% transparent BSDF

Hello estimated community,

I am animating an object disappearing slowly, for this I used a mix shader going from a diffuse BSDF material dropping onto a Transparent BSDF material. For some reason when the Transparent BSDF material is at 100% it still shows part of the geometry that should not be visible causing black spots to appear here and there. I don’t have a lead on what it may be causing it as the setup is quite simple.

I already checked the normals of the faces and they are looking in the correct direction.

Any guesses?

Blender version 2.79b
Cycles renderer

Final render with the shadow
RenderTest2

Links to my node setup and solid view

If you look at render settings, Light Paths, there’s some options for transparency - by default set to 8. This means that you can see through 8 transparent surfaces - after that they’ll be black. Your anim may work if you ramp this up a little.

1 Like

Thank you yogyog! it fixed the problem