Cycles - different alpha map for shadows?

Hi there, I have a gryphon character with some particle system with a lot of feathers (textured planes). I have some pretty high-res alpha maps on the feathers, which obviously take FOREVER to render with transparent shadows. Turning off transparent shadows results in around half the render time, but the shadows of the planes are too inaccurate and lead to big and blocky black spots between the feathers. Is there a way to use a high-res alpha map for the visible alpha of the feathers, and a low-res map for the projected shadows? Any help would be greatly appreciated. c:

The issue primarily is transparent shadows themselves, not the resolution of the alpha map. Your best bet is to try and edit the source planes so there is less empty space on each side of the texture. Don’t be afraid to add some loop cuts, final polygon count of particle instances isn’t really relevant. If you can trim it to the point that you don’t need transparent shadows, that would be best. But even removing some of the blank space will help.

Few ways of optimizing.

Transparent depth node and mixing the diffuse ray to a straight colour… sampling transparencies takes a while.

Something like this should work decently… change the colour2 to a colour similar to your feather colour…

The greater than node, is your transparent depth from camera ray.

The math add NEEDS the clamp… just to make sure that the ray is between 0 and 1.

Thank you. I’m definitely going to try that!

Thanks. Could you perhaps explain what this setup does exactly? I’m rather new to nodes, and I don’t know much about Light Paths.

I found a solution with the Light Path - Is Shadow Ray node. However, this doesn’t enhance my render times much…How can I turn off shadows on this material altogether? The feathers don’t really need self-shadowing, and I guess this could improve my render times a lot…

The problem is that in Cycles, it is not the shadows that are casted, but the light!! Having the shadow turned off, will not avoid shadow rays to hit the feathers, only to automatically render them transparent for the shadowray. The intersection between any shadow ray with the feathers will still happen.

On your first post, you asked if it was possible to have a different lowres mask for the shadows… yes, that can be done. Just use the ‘Is_Shadow_ray’ to switch between the highres and the lowres mask and use this result to mix your shader with a transparent.

Aw, you’re right. I tried making the shadows invisible with a node setup, and it took even LONGER to render…Well, I guess it can’t be helped and I’m gonna have to adapt the geometry so that the non-transparent shadows won’t be as obvious. Thanks for your help!

Trying to get rid of shadows in the node editor won’t work. The node editor can’t do that, it only affects the appearance of the shadow. You didn’t remove the transparent shadow, you made the ENTIRE shadow transparent. The switch for what you actually wanted is in the object panel, under ray visibility. Uncheck “shadow”, then it won’t render shadows at all.

I know this sounds cheesy, but I love you so much right now. I turned off everything except camera for all the feathers, since I don’t really need them to cast shadows or be reflected, I have the main model for that. This reduced my render times by 70 PERCENT! So instead of 1:33 minutes, it renders in 27 seconds! And I’m sure I can fake some minor shadows with ambient occlusion (If this doesn’t increase my render times a lot again, haha). I will definitely use these settings to optimize my scene. I’m sure it will come in handy with some volumetrics in my scene. Thanks!