Cycles GPU error, OpenCL version 1.1 required

Another question about cycles. I tried to turn it to GPU and it came up with this error: OpenCL platform version 1.1 or later required, found 1.0
I know it’s not my video card, and I did download the microsoft C++ package.

What card are you using ?
OpenCL rendering is very limited currently so if you want more than just a clay render use CPU rendering

I had that same Problem but I fixed it by looking at what My graphics card was and then going to there site and finding there most recent Update which was still beta. It works now.

I am getting the same error. I have an NVIDIA GeForce 320M on my MacBook Pro. It’s racking my brain because this chipset was apparently made exclusively for apple so finding specs on it has been difficult.

I’m also on a MacBook Pro (=no capability for changing graphics card), but it has an AMD card (there were never options for which graphics cards, so since when were NVIDIA cards used in their production?). I do have a windows partition though, and I’m trying to find some way to get GPU rendering working, even if it’s slower, but just to see how it compares. I’ve found this basically saying that OSX doesn’t even support openCL 1.1, but theoretically I could install the windows (or linux) software/drivers when booted into that OS and run a version of openCL 1.1 (or 1.2) there?
And in what way is openCL “limited”?

And in what way is openCL “limited”?

From the documentation

Rendering using OpenCL is not yet fully supported, but it is being worked on so we can support more graphics cards. Currently only simple clay rendering is supported, due to our full kernel not compiling with the AMD OpenCL compiler.

The first time rendering is done, the kernel must be compiled for your GPU architecture. Since Cycles is quite complex compared to a typical GPU kernel, compilation may take from 40 seconds to a few minutes, and may also up about 2GB of memory, depending on the graphics card model.

OpenCL version 1.1 or higher is required.

You want to render something with a bit of colour or transparency or with a texture with openCL, tough luck currently, which to me seems to be ‘limited’

My video card is an EVGA geforce gtx 460, 2 GB. Which is why I want to use it for cycles.

Hi there, Same problem here, I have a Nvidia GTS 450 and it tells me that I need Open CL 1.1 or higher and by now I just have 1.0, What could I do in order to update to 1.1? Is my system ok?

Thanks for any information.

Using Nvidia card you should use CUDA, not OpenCL. CUDA is fully supported on 4xx series and higher cards…