Cycles interior - noise even after 2000 samples

I’m trying to migrate my workflow to blender. After playing around with Cycles, I’m giving a shot with this scene. I was all yesterday trying different light setups: sun, world, arealights, point lights, meshlights, but in the end it all comes to the same: noise. So I let the thing cook for 5 hours overnight to get this noisy 2200 pass render.
Does it really need to be this way? This noisy? What am I doing wrong?

Attachments (571 KB)


Damn it’s hard to test someone elses work! I’m rendering on GPU, so it’s a lot quicker for me, although it does seem a bit slow to remove the noise, although it builds quick enough per pass.

I’ve not tested before, but you have a sun light and also a sky texture, which I’m sure will probably add to the render time - I could be wrong.

I imagine you’ve imported your model in from another program, max, maya etc. The whole model is full of triangles, it’s not good practice to have models made this way in blender, although whether that ulitimately effects render time in Cycles I have no idea.

You changed some of the defaults in the Render settings I think, what were the defaults like time wise?

Even though they are not visible, the other models, bath, sink, toilet, kitchen, are still getting rendered, I’d certailny move them to another layer if they are not required for the render.

Oh yeah, I also removed the floor as there was no texture (obviously) and the floor was render black.

Darn, wish I could be more help, I always find it hard to spot the obvious sometimes in others work.

Maybe some brain here will point it out to you, sorry I couldn’t help further :wink:

Can you post your ?noisefree? results and tell the number os passes?

I stepped into this thinking it was as easy as you using a glass material, but nooo, this file/scene is a total mess, hehe… You need to clean up the geometry, discard all but natural lights, assign cycles materials to all & any geometry, and that’s for starters… I for one would start over, modelling it all from scratch in Blender. It isn’t that much modelling anyway and will generate a cleaner scene. Also avoid using glass and/or caustics as that will give you more noise. :slight_smile:

I’ll try those advices and post when ready.

You should just keep in mind off of the bat that Cycles is a pretty abysmal renderer for indirect indoor scenes. It’s probably the least efficient lighting method for a path tracer.

  • Select the Material tab
  • select every material that you are using, and do the following, one by one
    – scroll right to the boottom and reach the Setting part
    – uncheck “sample as lamp” for every material ( or just one to check the difference ) and try this way

You may want to try and re-scale your scene to the correct size. Unless this is a doll house? The default cube is 2 meters high. So scale up your geometry with that in mind. Also, don’t use the sky texture more than once. Only on the background.

I get a fairly clean scene after a few hundred samples. The textures are missing of course.


With that in mind, what are my options with blender? Yafaray?

I love Cycles and it’s really impressive, but in some situations like internal scenes it just requires hours and tons of samples right now.
It will probably become much better over time.

Meanwhile I think you should give Yafaray a try.
I’m just beginning to learn Yafaray but it really looks like it shines for architectural and product shots.

I tweaked your scene with a wooden floor and a slightly blur mix node at the end make the scene a little softer look in Yafaray beta 3 for OS X 64bit.
Rendered on my 6 year old computer.

(direct lighting low settings 1:40 min)

(photon mapping more samples 10 min)

I switched off “samples as lamp”, deleted unused mesh geometry, and put settings to the attached image:
cycles settings
cycles 2000samples
cycles 5000samples
I could use yafaray… but I’m interested in correct light dispersion. And yafaray is missing border render; there is no floating preview window in blender; so it really is a pain to test render settings…

Sadly Vray is looking too good right now in comparision, hope Cycles gets some other rendering methods and definately some speed ups - early days I guess, roll on Mango :wink:

I think the big thing there is that they are totally different kinds of renderers. Vray and alike are awesome, but there’s a more photographic look to un-biased renderers that is hard to fake as Vray, MR & PRman kinda does… (well, un-biased rendering is faking to, hehe, but in a different way)

@rucativaia: Did you scale you geometry to the correct size?

I’m interested in correct light dispersion.

The light dispersion calculations are based upon units. Your posted scene is the wrong size.

Just for a protocol - fedora 15, 32 bit, nv gf9800, AMD Athlon 64X2, Blender 2.62.1 r.44615 svn; did not touch anything except added floor texture and changed some numbers on Integrator’s. This is a screenshot, so no compositing done yet.

A few of points. When rendering interiors, don’t use skymaps or background textures of any kind. Use area lamps in the windows, or just outside. Second of all, play with the integrator settings; the fewer the bounces the faster the render. Do not use glass in the windows unless you absolutely have to. In that case, use a single plane and mix some gloss into it to essentially fake glass. Finally, if you are not using the geometry in the render (i.e. the washing machine can’t be seen in that shot) then move it to an unused layer.

Maybe the wrong thing here is my 2.0 dual core macbook with no capable GPU…

My posted scene was rendered on a dual core laptop with no GPU. I doubt your hardware is the problem.

That might have had impact of render times, not passes needed to get it cleared out imho. You’ve had 5500 passes, but it looks different story tho. Did it pass compositing? And what had happened to that thing with switching BI color management off or on, should be corrected now for the new builds?
Btw i really like what cycles did here compared to sterility of Yaffa…

When rendering interior scenes with unbiased rendering engine the rule is to have more bounces than for exterior ones no ? I’m curios what happens to rendering times if you set yours to 128 for all the integrator bounces ? maybe 1 week :P?
Anyway setting the min bounces to equal the max bounces should give less noise in exchange of time yes ?