Cycles loses CUDA if I use Remote Desktop


(usenetfan) #1

Hi gurus,

I have a machine at the University on which I run an nVidia GTX580. It works great if I use it on the console, and I can turn on the GRU rendering which works very well.

But if I get a Remote Desktop session into the machine, I cannot turn on CUDA anymore, it simply is not in the options list. And if I go back to the console, it is there.

What should I try to fix in the RDP to get the machine to render on GPU even if I am home and come in using RDP? This has me baffled.

Many thanks for any pointers!


(usenetfan) #2

Another fun part: if I boot Blender on console, then switch to RDP and join the session, I have CUDA. So the question actually is… why can I not initiate a CUDA-capable session remotely?


(bashi) #3

i have noticed (on osx) that it makes a difference for Blender which GPU is active at startup. Do you have multiple GPUs in that system?


(usenetfan) #4

I only have the GTX580 and it is default in Blender user prefs.


(mib2berlin) #5

I had the same problem with octane (cuda only renderer) and vnc and rdp.
It worked with teamviever and teamviever is based on turboVNC.
After setup with turboVNC I have no problems.
May you test teamviewer.

Cheers, mib.


(usenetfan) #6

Good point, thanks mib. The only problem is, my Uni will not allow any other VPN than Cisco.


(mib2berlin) #7

Hm, teamviewer goes through all routers/firewalls and it is not needed to install anything
but I understand. :expressionless:


(usenetfan) #8

This was fixed in 2.65 after I reported it as a bug. 2.64 doesn’t bring CUDA but 2.65 does.


(swmo) #9

I still have this problem on 2.66a. It does not show CUDA as an option on Remote Desktop, although it does through the console or Teamviewer.


(Zalamander) #10

CUDA doesn’t work through the RDP display driver, it’s a known issue and as far as I know, there’s nothing Blender can do about it.

The only problem is, my Uni will not allow any other VPN than Cisco.

I don’t see how that has anything to do with it. You should be able to run VNC regardless.


(usenetfan) #11

There’s a workaround - use Splashtop Remote Desktop. Free for personal use, it also allows you to access the NVIDIA Control Panel.


(Reaction) #12

This is causing me serious problems too! I left my work PC turned on, rendering an animation on the GPU. During the night, the PC unhelpfully decided to install some updates and restart itself, killing Blender. Now, if I start Blender from home over Remote Desktop (via a Cisco VPN connection), sure enough my GPU is not listed any more. Even starting the render using a command line (i.e without opening Blender) doesn’t work. The only workaround I can find is to set the tile size to 16x16 pixels (see this: http://www.blenderguru.com/4-easy-ways-to-speed-up-cycles/) and let the i7 CPU do it on 8 threads. Takes 3-4 times as long as my [pathetically bad] Quadro 4000 GPU, but at least it will get a few frames done before I go back into work tomorrow… :frowning:


(usenetfan) #13

Install Splashtop Streamer on your remote computer and the correspoding client on your machine. Also, your firewall needs to have the ports 6783 to 6785 open (this caused me some problems).


(swmo) #14

I was using Teamviewer, but been trying Splashtop this evening and it is much much better. +1 to that recommendation.


(carlosan) #15

CUDA doesn’t work through the RDP display driver

UltraVNC works fine too


(doublebishop) #16

We have been using tightvnc for network based control for blender as we ran into the same problems with RDP… seems like RDP doesnt actually initialize the gpu properly and is more of a shell then a desktop viewer.


(powerst) #17

Same for me. I use tightVNC for things like this. RDP causes problems with a few of my apps because of the way it emulates a video and sound device.


(usenetfan) #18

hey, glad that I could finally be of use here :slight_smile: