"Cycles" options not appearing in 2.9: working on same machine in 2.83

I have both 2.9 and 2.83 on the same laptop. 2.83 shows all the appropriate options for Cycles in both the Properties panel and the Preferences/System panel, but 2.9 doesn’t have any references to Cycles in either. Same machine.

What’s going on?


What is your operating system? What is your GPU?

Solved it: to my surprise, CYCLES is an add-on (!!!) , and must be installed like any other addon. It does, of course, come with the standard download.

Noobs, learn from my confusion!

It’s not your fault. This is a bug, Cycles should be enabled by default.


Yeah, it’s pretty dumb that it is not.

But, Blender devs do a LOT of dumb things – IMO they’re not called out enough on it. This is extremely low-hanging fruit.

To be clear, that bug appeared yesterday and was fixed today, less than 24 hours later, so it couldn’t have been the cause of @Jeric_Synergy’s issue.

It’s weird. In that case it was either another bug or @Jeric_Synergy accidentally disabled Cycles at some point. Or maybe some new addon disabled Cycles? I’m not sure if an addon is allowed to do that (in terms of Blender security/safety)

Since I didn’t know Cycles was an addon, I certainly didn’t disable it manually.