Cycles Realtime rendering is Yellow

I just started using Blender 2.77 on Linux and when I use the cycles realtime rendering it has a yellow tint to it, yet when I use Blender Internal Realtime Rendering, there is no problem, nor is there a problem when I render an image using Cycles, only with realtime rendering

Cycles Realtime Rendering:

Blender Internal Realtime rendering:

Cycles Render:

Any Help would be appreciated


Please ALWAYS supply an example .blend file with any support question.
How are we otherwise supposed to give an answer? By clairvoyance?

It isn’t with a specific blend otherwise I would’ve posted that .blend, this is with any realtime previewing I do in cycles with Blender 2.77 on Linux Mint 17.3. There isn’t much more I can show besides screenshots. I have tried with other .blend files as well, which means it has to do with Blender, not a specific .blend.

or specific system, or hardware, or settings… why blend is needed, to compare :eyebrowlift:

I suppose I can upload a .blend, but I really don’t think it’ll be much help.
example.blend (458 KB)

Renders perfectly fine here with 2.77a on Windows 7 Ultimate x64 and ubuntu 14.04.4 LTS x64. So this is not a Blender thing, but must have another reason.

Something’s weird with your screenshots, though. Do the viewport renders and the final (F12) render show the same scene? If so, why do the former have 4 objects / 2 lamps and the latter only 3 objects / 1 lamp?

Have you tried an older version of Blender, like 2.76?

I expect that this is a driver issue. I’ve had all kind of insane and unpredictable video driver issues with Linux.

Tested on 2.77 / 2.76 win7 x64, NVidia GPU, Intel Xeon X5650, latest drivers - no problems.

Probably should check your drivers or settings as suggested.
Info on your system and configuration will be needed for further assistance.

Yeah, the one with the render is a different blend file, but the issue was the same, the blend file made no difference.

I’m using Intel Core i7-6700, no GPU (maybe IntelHD Graphics is the problem?), Linux Mint 17.3 x64.

It has something to do with the Blue Channel, but I’m not sure how to correct it, as you can see in the below screen-shots, Green displays fine, Red displays fine, yet blue turns to black, leading me to believe that the Blue channel is being omitted, yet I have no idea how to fix this problem.


Here are some things to try:

  1. Download Blender 2.77 again and unzip it to a new location. See if the new Blender “install” works. This will ensure that it isn’t some odd preference that was changed. If this doesn’t fix it, the issue is related to your system, not your settings.

  2. Download previous Blender versions and try them. This will determine if the problem is new with Blender 2.77. Try Blender versions before and after the viewport updates. This is to see if your system is having specific issues with certain software features. I don’t know how Blender functions internally, but I suspect that the viewport renderer relies somewhat on the graphics card, unlike the F12 renderer. This would explain why the issue only happens in the viewport. I don’t know why this wouldn’t apply to the BI viewport renderer.

  3. Try it with the GSL shaders in the viewport to see if they have any issues.

I still think that this is GPU driver related.