Cycles Render only rendering part of the image

This is my first time using Cycles,
I don’t know what I did but Blender is only rendering a small area near the tire of my truck.

What settings must I play around with to have the entire camera’s view be rendered?
I’ve been playing around with a lot of the settings trying to rid of this horrible grainy effect, not only did it not work, but the image isn’t being entirely rendered :spin:

Where did I go wrong?!
Thanks!

Have you enabled border render ?
Objects outside camera clipping distances ?

Where did I go wrong?!

By not showing us anything

That being “Shift + B”?
I have not, found that out by looking at older threads with the same question.
It’s got nothing to do with the camera, I haven’t touched it at all.
Played around with the dimensions, they’re set to 760x and 620y (or something like that.) Putting them back to default zooms it in even more

By not showing us anything

The most I could show you is this:


…unless you want me to take a screenshot of every setting in the Properties window.
I’m not quite sure what I touched, about ready to load everything into a new file :S

The image quality gradually gets better over time, but doesn’t load anything else.
Also, splitting the screen in two and setting one of them to Viewport shading “Rendered” displays the image just fine

Look at the status bar at the top, where it says “Path Tracing Tile 2/42”:
Other than the rendered viewport the final render is by default rendered in tiles - in your case 42 of them. Obviously you’re rendering on a rather low end machine, that’s why only two tiles are rendered simultaneously (one tile for each thread). As soon as any tile has reached the designated amount of samples, Cycles will go on to the next, thereby revealing the image tile after tile. So, just wait a bit longer, and larger areas of your render will become visible.

I’m a bit confused, though: Shouldn’t you know the tile principle from Blender Internal?

Anyway, if you want the final render to behave like the rendered viewport, you need to enable “Progressive Refine”:


Hmm, yeah. My laptop isn’t too great.
Last night it loaded the entire thing nearly immediately, (5-10 seconds) and from there it’d start improving the quality, as the initial render looked awful

I deleted everything in the scene (to try and speed things up) but it still doesn’t reveal the rest of the image.
I’ll upload the file, see if it affects you too.

http://www.pasteall.org/blend/31257

Deleted the truck so no one can steal it >:]
…not that anyone would want to, anyways

What is your samples setting?
If set too high, each tile will take very long to render and Cycles will not progress to the next tiles for quite a while…

EDIT
Holy overkill! 10,000 samples? Try 250 - 500 for starters and maybe increase that later if the render is too noisy…


This is rendered with 150 samples. Render time 23 seconds on a rather old first gen i5 notebook.

Read somewhere that that’s a way to remove the film grain effect.
Figured that’d be it, but it still won’t load. Did it load for you?

EDIT: OH, set it to 1 (not 10, or 100) but 1.
It actually loads! Hooray!
Setting it to anything higher than 50 takes too long.
I’d assume that you’d raise the value for the final render?

EDIT 2 : Can’t stop giggling over “Holy Overkill” xD

Tried rendering the same file with 150 samples,
so far I’m at 3 minutes 30 seconds, with only 20 frames loaded.

Well, thanks a bunch Ikari!
I’ve only every used the game engine before, not used to all these different settings and terms…

Thank you! :ba:

EDIT:

Anyway, if you want the final render to behave like the rendered viewport, you need to enable “Progressive Refine”:

Ah, this should come in handy. Thanks!

Well, I can honestly say that I never needed 10,000 samples on a final render…:wink:
I’d say 1,000 to 2,500 samples max will suffice in most cases.

May I ask what kind of notebook are we talking about on your end? From the performance you describe I would guess: Netbook?

EDIT
Oh, and mind you that “Progressive Refine” will definitely increase the render time and memory consumption…


Pretty pitiful, I’ve had this for as long as I can remember…

Dont use progressive refine and set the tile size to 8x8

Was a bit skeptical about doing this, it’s fantastic!
Got the truck to render in 44 seconds.

Thanks for the tip, very helpful! :]

You can experiment from there. Try 4x4, 16x16 etc…

Thank you very much!
I’m not one to watch hours of tutorials, so I really appreciate the tips!

Think I can close the thread now…
unless there are any more things you’d wish to share :eyebrowlift: