Cycles Rendering Artifacts

I have searched but found no solution. I’m getting artifacts in cycles render, and in viewport when I use the Rendered mode. I managed to eliminate them when I used subdivision modifier, but the moment I Apply the modifier, the artifacts are back again. Anyway, I don’t want to have to use subdivision every time, sometimes my mesh is already the way it’s supposed to be. Here are quick renders for comparison:

  1. low resolution, no modifier.
  2. With Subdivision modifier on
  3. After clicking the Apply button

    These artifacts have been plaguing me since I started using Blender. I don’t know what to do with them.

The issue is called terminator effect. Where strongly directed light hits a surface at a grazing angle, one gets this kind of blockiness, even with smooth normals enabled. Version 2.81 has a feature to reduce the effect, but the simplest (and likely most common) approach actually is doing fine enough subdiv.

Where I’m stumbling upon, is that applying the modifier makes a difference. Are these all final renders and the subdiv modifier had different settings for viewport and final? If yes, applying the modifier uses the setting for viewport, and thus you would have a lower subdiv level in the third image compared to the second.

1 Like

I think that reduction only affects bump mapping on diffuse shaders.

I assume, yes. I didn’t try it yet, but that’s what the changelog says. Good to point it out, as the OP probably wants to add glossy later.

I have completely forgotten about this topic! Well, my late thanks to you for responding. The problem does persist for now, but you’re right, @omgold it’s the resolution, and the modifier does have a different effect after being applied. On the bright side, when I export the model to the game engine of my choice, the artifacts go away, and for now that’s what I need most.

P.S. I don’t know if I should’ve have marked the reply as Solution, since it’s more of an explanation, there really doesn’t seem to be a true solution to this, only workarounds and compromises :thinking: