Cycles Rendering Grey Foggy Result

Hi, i have a AMD R9 280x when i render any project on cycles it’s giving a result like this;

But with CPU it’s rendering without error. And on 3D View if i set method to display to “Rendered” GPU working correctly, i mean no any fog and gray screen like that.

I found a solution for render with GPU but it’s making my render time so slow

Here if i enabled it, i can render without problem but people who have same graphic cards like me rendering same scene 1 minute 30 sec i am rendering about 3-4 minutes.

My amd driver updated latest version 16.9.2

What is the possible solve my problem… thanks

hmmm, not sure?

maybe look on here -

It may have some info on there to explain the issues you are having?
(I haven’t looked through it yet, but i know your card is mentioned on there)

edit - just checked and it seems to be that your card IS supported and should work with cycles… strange, sorry i cant help you further, i’ve used only nvidia cards for years. so i know next to nothing about AMDs really :confused:

Maybe try setting the feature set in the render tab to “experimental” instead of “supported”? not sure if that will do anything, but its worth a try

if all else fails, try posting a new thread in the technical support section of the forum… maybe someone there who knows about this sort of thing could help you

yes i tried experimental too, it’s same error but before that i mean 3-4 months ago i can use my gpu render without problem… but now i it’s giving a foggy screen at render. but in 3D view if i set the view mode to rendered view its have not problem… im confused. but i will never buy an amd card again. spend more money and buy nvidia atleast you can use it damn…

thanks for your help