Cycles smooth shading broken/Shadow Terminator problem?

Hello there!
So suddenly Blender started to glitch when I create a sphere and put the shading on smooth.
I have no clue what happened, I had Blender installed on the same system and suddenly this glitch appeared. I tried to remove Blender and install older and newer versions, this problem is in all of them. Which is super weird in itself, since everything was fine until now (I updated Blender to 2.82a).
So it seems many people report this as a bug for years now but still no solution. There are suggestions to add a sub div modifier or add more geometry, but that seems rather complicated for such a simple thing? Eevee is fine.
Any other/new solutions to this?


Only ways to deal with terminator effect is to add geometry/subdiv levels or increase the lamp size to make it smoother, or reduce the effect by adding opposing lights as well.

Is this really the only way?
I wonder also why at some point everything was fine and then suddenly this bug appeared.
Which means it can go away completely

Here is an older thread on the subject:

cycles has had the terminator artifact from day one, it’s the nature of ray traced shadows. some renderers build in a workaround, but not yet for cycles.

I wonder though, why wasn’t it there before and is there now.
It must mean that it is possible to have good smooth shading visualization on cycles.

The glitch has always been there. It’s not really even a glitch per se, it’s just a limitation of normal smoothing. It can be hidden by both more geometry, or by softer shadows (spreads out the terminator). Something you did made a sharper shadow on a low-res mesh, or maybe you just never thought to look for it.

But I can assure you it’s always been there and is not something you broke just now. Unless you accidentally turned off a subdivision modifier or something.

You almost certainly were doing something different. It has always been there, maybe you got lucky and never made a scene that made it obvious.

Maybe :smiley:
A friend of mine says his Blender also shows everything normal. No terminator…

pics or it didn’t happen. :slight_smile:

Haha :slight_smile:
Judging by all the info and different tests, it really seems to be the render engine problem. It shows up the same on my working computer that has amazing specs. Really too bad. I guess we have to work around and wait until some other solution might come up.

Kinda crosspost, but…
One workaround is to use a diffuse Toon shader instead of regular lambertian Diffuse. Tweak the size and smooth values to shift the terminator towards the light source. Might not work with other shaders where you lack this control.