Cycles Volumetric Rendering

Incase you didn’t hear, volumetric is now in trunk as experimental. There’s a Strand Rendering and SSS thread here, so I thought it would be good to have one for volumes, as things easily get lost in the easter egg thread.

Here’s the documentation, hope some information can be discussed here, technical or not.

Download recent build to try…

as of the date of this post, is anyone having trouble setting up a world volume material ?. I just get black. I’m not sure if its a bug or if it hasn’t been supported yet.

Also special thanks to Storm, Stuart, Thomas and Brecht.

Put nothing to the normal “Shader output”, just use “Volume Absorption” into the “Volume” node of the output. You also need to switch to CPU rendering, as GPU isn’t supported yet.

Nice thread, looking forward to all the great tests. :slight_smile:

simple tests

for more details, catch me on twitter

nope, still can’t get it to work. This works for objects, not world.

I have volume node plugged in volume input of world output node. I get black. I have it set to cpu and experimental. It works on objects though. i’ve a feeling world isn’t supported yet?

great tests zuggamasta, can we see node setup for second example?

thats cool… would it be much faster with gpu? cpu is realy fast!

It can be merged, mods can decide. This is trunk version, more finalized design wise, versus dingtos gsoc build. sorry, its still “latest news” though.

im just a little butthurt that no one started talking :frowning: hugz for everyone

awesome… thats amazing fast on cpu… realy cool and thanks for the link LordOdin and ng-material!!! makes me happy;)

good night and a happy 2014!

Hi, I activated GPU rendering in my build.
On my system it is ~4 times faster than CPU and work without problems.

GPU 01:28.90
CPU 04:52.06

Cheers, mib.


had to try some Halo’s, needs a little more work to get the proper effect but meh, close enough!

you need world volume to get the light ray effect with a spotlight, but as I posted, it doesn’t seem to be working at the moment.

Whenever I have a world volume material, It does indeed black out any light from the sky, but if I add a lamp or emitter, then I can see things. since there is no volumetric scattering (yet), it only acts as a sort of mist pass.

ng, have you tried using other lights in the scene?

world volume, i see. i tried a number of ways to recreate the effect, eventually hitting on mixing an emission with the volume and faking it with meshes. it seems there has been a change as in another thread someone mentions a “G” parameter, that no longer seems to exist and the node is named differently. so basically just messing around until interesting things happen :slight_smile:

yes, I tried all lights.

maybe volumetric scattering is exactly what it is? because i’m not familiar with the terminology, maybes thats my dumbass fault for trying to get something isn’t here yet.

now that I look, there is no scatter function in light paths like there was in dingtos build, so thats probably why I get black. Its not supported.

so small troll, it looks like the official term is volume scatter, you’ll need this for your light ray effect.

right now it seems to be object only. My mistake.

someone can correct me if i’m still wrong here, lol.

The reason you’re not getting light rays yet is because the current trunk builds only support volumetric absorption, not scattering.

With absorption, the rays will just travel through in a straight line (picking up color or texture information along the way). Light-rays require that the rays are constantly splitting as they travel through the medium (which that functionality has not yet been ported from the DingTo branch).

Basically, the strategy being employed is to introduce various features and effects one by one so they can ensure that the code is clean and commit ready when it’s included in the master branch. The commit logs note that Broadstu is also helping with the cleanup and implementation effort so it’s going a bit faster than it would otherwise go if it was Brecht alone.

thanks for clarification. I had assumed because it was available in dingtos build (and it worked really well) that it would be here.

this is what happens when you get too excited and don’t pay attention. I go like this " DEEEEEEEERP DEEEEEEERP lets plug volume absorption node in world even though it clearly says absorption DEERRP DERP why is black?, Y iz not workingz?!?! derp derp derp"

Hey, that’s good news!

Hi there,

A quick test for some gemstone material:

(I found absorption only, I may missed something, anyway)
Has anyone tried to combine this volume shader with a translucent shader - setup?
he he