Cycles-X

Yeah, do you know how to contact the developers about hardware issues like these?
i could even help them making tests if they wish.

I guess there:

1 Like

does any one know why i am getting this error


this is from the latest blender 3.0 beta build

Hi, if this only appear on heavy scenes it is a driver timeout setting from Windows.
Search for “nvidia timeout registry” and change/add the timeout setting.

Cheers, mib

this is only default cube but i did not get this error from the old build like when this was in alpha

Hi, no idea but i cant reproduce it with the beta build from today on RTX 2060, driver 471.41 on Windows 11, all default settings.
Maybe another user can reproduce it.

For more info about the timeout problem: https://substance3d.adobe.com/documentation/spdoc/gpu-drivers-crash-with-long-computations-tdr-crash-128745489.html

Not only Blender have this problem.

Cheers, mib

Hey I finally found the issue. The 3.1 denoiser was heavier on my processor. I could get rid of the crashes by downcloking the avx 512 instructions. Thanks for testing! :slight_smile:

2 Likes

is it currently accessible ? I do not see the adaptive subdivision in the subd modifier.

You need to enable the experimental feature set.

In render panel yes I did !

The SubD modify remains the same.

Is that because I use max is arm blender beta ?

I guess you have to put the sub-d at last. It works with only one sub-d modifier or the last modifier in the list as sub-d.

1 Like

ROYAL FACE PALM TO MYSELF

Cycles X seemed amazing to me when I didn’t have Nvidia GPUs and used CPU rendering. But when I bought a laptop with RTX 3050 some problems popped out. Cycles X uses more video memory and OptiX fails to work on many scenes. And CUDA rendering with Cycles X have the same render time as OptiX rendering on 2.93 and sometimes even slower. And another problem here is that files saved with 3.0 beta doesn’t correctly open with 2.93. I wish I could convert blend files from 3.0 to 2.93.

Do you use both CPU+GPU for rendering?
I noticed that if I select only GPU / Optix on my Laptop and on my Workstation it renders much much faster than when using both CPU+GPU. I hope this will be tackled one day because it’s so sad to see a powerful Threadripper with 64 cores literally do nothing while the GPU does all the heavy lifting.

I tried both options and it doesn’t affect render time at all for me.
BTW Optix+CPU rendering fails for me on 2.93 too: GPU renders properly and CPU renders black tiles. CUDA+CPU works fine on 2.93, but on 3.0 render times are the same for all GPU+CPU renders.

Strange… maybe a silly question but do you use the very latest drivers? Optix features depend heavily on them.

I currenly use 470 drivers on Manjaro Linux. I can try to install experimental 495 drivers.
Yes, my problems can be Linux-specific…

I’m on Linux, too. I use 495 drivers and they work fine.

Installing 495 drivers fixed issue with OptiX+CPU rendering on 2.93 but under 3.0-candidate the problem persists:

OPTIX_ERROR_INVALID_VALUE in optixAccelBuild(context, __null, &options, &build_input, 1, temp_mem.device_pointer, sizes.tempSizeInBytes, out_data.device_pointer, sizes.outputSizeInBytes, &out_handle, use_fast_trace_bvh ? &compacted_size_prop : __null, use_fast_trace_bvh ? 1 : 0) (intern/cycles/device/optix/device_impl.cpp:1055)

Refer to the Cycles GPU rendering documentation for possible solutions:
https://docs.blender.org/manual/en/latest/render/cycles/gpu_rendering.html

Error: Failed to build OptiX acceleration structure
Error: OPTIX_ERROR_INVALID_VALUE in optixAccelBuild(context, __null, &options, &build_input, 1, temp_mem.device_pointer, sizes.tempSizeInBytes, out_data.device_pointer, sizes.outputSizeInBytes, &out_handle, use_fast_trace_bvh ? &compacted_size_prop : __null, use_fast_trace_bvh ? 1 : 0) (intern/cycles/device/optix/device_impl.cpp:1055)

On another scene error is slightly different:

Invalid value in cuMemFree_v2(mem.device_pointer) (intern/cycles/device/cuda/device_impl.cpp:802)
Error: OPTIX_ERROR_INVALID_VALUE in optixAccelCompact( context, __null, out_handle, compacted_data.device_pointer, compacted_size, &out_handle) (intern/cycles/device/optix/device_impl.cpp:1090)

UPD:
I solved the problem with the second scene. I just needed to change hair type to “Rounded ribbons” instead of “3D curves” and it lowered the render time from 20 min with CUDA to 3 min with OptiX.

In Blender 3 the compression method when saving files has changed in favour of a way faster and efficient algo.
If you want to open blends file with older versions you still can thou: just make sure to save without compression, and you should be able to open without any issue