Cylinder as a background, but now objects are super grainy, lighting issues?

Hi All,

I have been modelling with blender for a few weeks and finally wanted to add a background,

using cycles renderer. im facing a few brightness and additional grainy effect…
when render without the cylinder visible and render output looks really good.

Instead of using background from the properties tab (currently setup as surface background with a white colour and a strength of 1, which generates lighting for the model and my scene.), I have used a cylinder, I made a seam along the side, removed the top and bottom face from the cylinder to let light in, adjusted the UV and made a material to show the forrest photo im using.

sadly when the cylinder is being rendered it blocking massive amounts of ambient light and causing the model to become grainy.

***** the cylinder is very tall!!!
Lets state that if my largest object has a height of 10 scale units, the cylinder is at least 60 scale units (6x taller)

The Material for the cylinder is setup as follows,
Surface: diffuse BSDF
Color: Image texture (Color/Linear/Flat/Repeat/Single Image
Vector: Default
Roughness: 0
Normal: default

Volume: None

Displacement: default

I have ticked multiple importance and transparent shadows. as they are ticked as default.

can anyone help me with this?



I found that going to the object panel, you can disable Cycles relevant checkboxes at the bottom which turns off things like shadows etc.

You seem to be going a long way around this. Try the World nodes for a simpler solution.