Cylinder Cap Problem - Faces not part of object

Hello all!
I’m fairly new to modeling, so I’m probably missing something fundamental when doing this model.
My problem is here, however, that I’m trying to get all quads on the end caps of a cylinder. I’ve got it all right, with vertices connected and created faces from them. It’s all good and dandy in editor mode, but when I swap to object mode, they suddenly disappear as if they’re not really part of the mesh.
My ultimate goal is to apply a subdivision modifier, but as the faces aren’t part of the mesh (or are they?) the subdivision goes all crazy on me.

Here’s what it looks like in editor mode

Object mode

And what the subdivider does because of this

The edges are there, just not displayed because they are all on a planar surface.

Enable ‘Draw All Edges’ so you can see all the faces

Thanks, they show up properly now!
What about the subdivision problem? Is there a trick/workaround I can use to avoid it smushing the top together like that?

Nevermind my last post, I sorted it out myself!