Dark blotches on fur

I’m doing a tutorial here: https://www.youtube.com/watch?v=bqEUZ-pQWFI I can’t get rid of the dark blotches on the face. Can someone tell me why they are there and how to get rid of them?


Blend file: http://www.pasteall.org/blend/30901

Short answer:

  1. Change subsurf to viewport 2, render 2
  2. On the hair systems click ‘free edit’
  3. Check the checkbox ‘use modifier stack’
  4. Recomb it.

Long answer. Well, let me know if you want that one. Cool dog!

Thanks for responding. I can’t check the checkbox “use modifier stack.” It’s grayed out. I did recomb the face. Although slightly better result, it’s still very noticeable.


Make sure you are in object mode.

Click ‘free edit first’, a popup will appear that says ‘you will lose changes done in particle mode’ click it, or ok, and then the checkbox will become enabled.

Yes! Success!! Very much appreciated. Does it have something to do with where the subsurface modifier is in the modifier stack? I have too many questions. Anyway, I can finally move on. I spent so many (wasted) hours in particle edit trying to get rid of the blotches. I have two particle systems (per the tutorial). One for the face and the other for the body. I just fixed the fur_face particle system per your directions. Should I do the same with the fur_body particle system? The body fur seems to have improved appearance even though I didn’t do what you said to do with that particle system.

I wonder why he didn’t mention to do this in the tutorial.


Its a great looking dog. A few things to think about:

  1. The segments. You have them at the default 5. You could probably easily lower this to 3 or 2. This will allow you to increase the particle numbers without slowing render times.

  2. The particle numbers, you have them both at the default 1000. It seems to be about right, but you can certainly increase or decrease these numbers. You do have to ‘free edit’ and lose your combing to change the parent numbers though.

  3. In the particle system, under display, there is a setting called ‘steps’ default is 2. You can almost think of this as a subsurf for the hair. It’s much more important on longer hair that has alot of curve, but you can increase this number to get smoother hair, without any zig zag look. Take note that increasing this also increases render times.

  4. In the children section, again you have render at the default 100, this may to be too much or too little, but can be changed.

  5. In the children section there is a parameter called random. Experiment with increasing this from 0 to .05, .1 , .2 or smaller. This adds some random noise to the hairs and helps fill it out some.

But excellent pooch, you should start of WIP with him (or her)