Defocus-Node doesn't do anything


This is my first post in this forum, so a big hello to all :slight_smile:

I’m very new to Blender and try to create a “Lord of the Rings”-Ring lying on a wooden table with a stone wall in the background. I got the basics right now and wanted to extend my szene with some compositions. So i toggled the “Do Composite”-button to enable compositing and opened the Node-Editor. There I switched to the composite tab and checked “Use Nodes”. Afterwards, I removed everything in the editor, created an input-node (Rendered Layer), the Defocus-node (set up like the one in the defocus-manual on and the composite-/output-node. Off course, everything is connected as needed. I don’t have a clue what I’m doing wrong… It’s the same with some texture-nodes. has very less examples on using nodes, and I’ve already searched all important sites twice. Maybe I’m just stupid :stuck_out_tongue:

The Node-Editor:

Here’s what I got after rendering; you see, no blur:

Thanks for every help in advance,

first drag the z from the render node to the defocus node, then unselect no z buffer, then make sure ‘do composite’ is on in the render buttons. Then mess around with the settings till you get what you want.

Ok, thanks, that helped for me. I setup the focus point in the camera to the ring’s position, but the rings is still blured… the ring should be the center of the focus and completly sharp… Can anyone help me with that, please?

Thanks in advance,

Adjust fstop to change the amount of blur. If this doesn’t work, could you post a blend?

Ok I got this to work too, but there is one last problem.

As you can see on the rendered image above if you look closer, there is a almoast invisible writing on the ring. In the node editor i tried to colorize this writing from white to red and this worked, i think, but i would like to have the writing “glowing”, like it is emitting light. Here’s an exmaple of what I mean:

Lord of the Rings Screensaver

Is there a way to get this effect using compositing and can i find a tutorial about that somewhere?

Thanks in advance,

Yeah, it is kind of annoying…

You may want to try Lux, one of the great things about the Lux external renderer. It works like a real world camera. Set your F-stop, your iso, film speed and your DOF.

Hm, isn’t that possible with the blender internal renderer?

Everything looks nice except the ring; this is blured even if the dof is set to the rings position… Setting down the Z-Scale to something below 1 only decreases the whole effect, not only the ring bluring…

Thanks in advance! :slight_smile:

You on the right track, just nodes are a pain, IMO. I find the defocus node produce low quality output.

It could be that the Defocus-Node produces low-quality images, but my image isn’t usable. I’ve seen images that look nice, even if there is some loss of quality in the end, here for example an image from the official defocus manual-page:

You see, the middle robots are completly sharp. Here’s my image:

Isn’t it possible to even get the ring focused? I don’t want perfect quality and I don’t need an artifarct-free image :smiley:

Thanks in advance,

Zscale-value does NOT adjust the location of the focal point.

The easiest way to control the focal point is to create an object (an Empty would be fine) in the 3D viewport, and put it where you want the camera to focus. Then select the camera, press F9 and copy the object’s name (Empty) to the “Dof Ob:” slot.

In the node editor you might have to set the fStop value of the Defocus node really low (depending on the scene). And like Excalaberr said, remember to deselect “No zbuffer”. Hope this helps.