Denoise All Render Passes


(elecopper) #1

Hey all,

First post for anything Blender for me, anywhere. So I’m new to a lot of this :slight_smile:
Apologies if this is answered somewhere else, but I couldn’t find an answer.
I’ve rendered a single scene with with all Direct, Indirect, and Color passes enabled (a few others too). Saving as a single OpenEXR Multilayered file. Then I’ve combined them all back together again in Natron.

All works great and the composed result would be the same as the Combined, apart from there is no denoising being applied to any of the passes. The Combined is denoised fine.

Additionally, if I set up a scene for each pass (one for Direct Diffuse only, another for Indirect Diffuse only, etc), the combined is still rendered and denoised regardless, and the pass is still not denoised. Even if it’s the only thing selected for that scene.

Question: Is there any way to denoise all of the passes at render time the same way as the Combined? Or perhaps, choose which passes to denoise?

Cheers


(Master Heavy) #2

is there some solution for those un-denoised diffuse passes - I face the same Problem actually…


(lolwel21) #3

Unfortunately, Cycles does not have an option to denoise the render passes. The best you can do is get the “Denoise” passes in Experimental (data the denoiser uses internally) and try to patch together a custom denoiser in the Compositor, then export the processed passes in a multilayer EXR.