Denoising artifacts with random colors

this is the render with random colors and denoising, there are artifacts

this is render whit random colors without denoising, there arent artifacts

this is the render with single color and denoising, there arent artifacts

can I fix this or it is a bug?

this is the file blend

tnx in advance :wink:

I am not sure if this problem has been reported before and if this is a known issue. But soon 2.79a will be released, and it is necessary to report it quickly. Please, report the problem here:

Top left, under BF Blender, Report bug button (So developers will decide if this is a bug, invalid node setup or whatever)

:confused: i assume are those NaNs again… yuck

ay-ay & it looks like all vector/normal values (Violet) produce those, if pushed directly into the color channel (Yellow) of any Shader - guess the denoiser still has issues… funny to see the dark matter in a glass after it’s denoised :slight_smile:

So how to bypass this limitation… to efficiently/productively translate vector to color?
Splitting, then combining RGB doesn’t work. Look around, found Converting Normals to RGB (BI). It also works with Cycles.

SOLUTION: Pass Normal/Vector through Color > HSV node.

Didn’t look further.

But was also tinkering, as on some occasions i prevented smaller mishaps by rendering at higher resolutions… could also super sampling help cycles to make better quality results in less time, if it could be implemented?

tnx you all!!!
if add HSV node the rendering is correct
I have however reported the suspected bug

It’s about negative values which denoising smooths out with positive values and results to artifacts. Getting rid of the negative values fixes it. Adding hue/sat node clamps the negative values, which is why it works.

Could also enable min 0 on the mapping node, or use mixrgb node with clamp enabled (add 0, or mix itself).

I’m not getting as severe artifacts with the test file as OP. Rendering with CPU.

Thanks for explanation & another solution :slight_smile:

That is curious. I get similar result as OP with CPU too. On Linux, intel i7-3770

Right. Figured out the difference. I get the same result with 2.79 release.

I was opening the file with an old development build. Said 2.79 on the header so didn’t think of much of it. I’ve commented these on the report.

Tested with release version, the old build I had, and the latest build. Release and latest build give the same artifacts, and removing negative values fixes denoising in all of them.

Hello everyone. Lukas fixed the problem:

What I’m not sure is if the fix will be included within 2.79a, it is in master branch but I do not understand very well what things from master will be included in 2.79a branch.

im getting the same problems. im using the latest 2.79 build. The artifacts for me are happening where light is escaping from near a 3D lightbulb that has huge emission values, and i have SSS turned on near it. Im guessing its running into some wacky effect or values somewhere near it. I don’t understand what these negative values things are or how to fix them. I’m not aware i have any negative values in the scene. The problem went away after compositing nodes had worked a glare effect on it, it turned into a red star streak effect which kind of worked, considering it was SSS light escaping through vents in a metal lampshade, so i would expect reddish glare anyway.