Denoising renders black tiles

Whenever I activate denoising in cycles and render with GPU everything works fine, but in the end the denoising results in black tiles and a completely black image. When I render with CPU it renders fine and denoising works great. I tried different settings but without success.

I’m using an iMac 27 late 2014 with a AMD Radeon R9 M295X 4GB, as far as I could research this card is supported by Blender for OpenCL rendering. It is also chosen in the preferences.

I made a simple test file with the standard cube:

denoise_black.blend (488 KB)

Thank you for your attention!

1 Like

Hi Docmatek,

I am having the exact same issue when I render with GPU and denoising, Im running the new iMac Pro 10 core Xeon 3ghz, 64gb ram and the Radeon Pro Vega 64 16GB GPU. anyone have any ideas?, also tried the cutting edge build and that still renders black tiles

1 Like

I am to facing this issue in blender

Same issue here. Anyone have any answers?

I am using the Intel OpenImageDenoise setting. But I get similar with other settings. Also I am using the GPU Compute and I have an RTX 2080.

Blender version 2.91, I don’t remember having this issue in 2.83.

Denoising off:


Denoising on:


Someone suggested using the denoise node instead, but it is blasting out the hair:


EDIT: An update. I did make some changes and the black dots went away. The only major thing I can see I did different was to turn off the environment texture, and set the BG to black so I could better control the lighting. And I also switched from a close area light I was using as a key light on the right to a spot. I also used less of a brute force method and added Adaptive Sampling which helps to focus more samples on the hair. Honestly I don’t know which one of these things did it.