Depth of field and F-stops


I am currently experimenting a bit with depth of field using F-stops and metric scaling that is supposed to compare to the real world. My problem is that I seem to have to go really, really low on F-stop to even get any blurring or shallow depth of field happening.

I feel like this is not true to the real world in any way. If I set up a scene with comparable scale to a real world scene, and take a picture on say F-stop 1.8 with my camera, that same scene with the same camera settings in Blender will have virually 0 DOF until the F-stop is like 0.004 which is just not realistic at all.

Does anyone have any of the same problems? I don’t want to fake the F-stop number to get shallow DOF.

1 Like

Could you please post an example scene for this behaviour?

I will come back to you with a picture from real life and a simple Blender scene to mimic the size, distance and camera used so you can better see the problem I am facing :slight_smile:

That will be helpful!

Hmm, are you sure that your object scales in the scene are correct? Here’s a scene I did with the base square at 2M (2 Blender Units) and then scaled everything in the scene down to 50% and then 10%.

In the first image the grid texture each square is 2cm, 2nd is 10cm and 3rd is 20cm.

I am trying to work in the correct scale, but I am sure I must have done something weird if you get the correct behavior. I have set Blender to metric by choosing “millimeters”. The ruler shows that my object is about 20 cm high which is what I am looking for. I have applied the scale also, after scaling it up quite a bit to get the correct height. Are there any other ways of adjusting scale outside of this that I am not aware of? I am kind of a newbie.

Thanks, picture and scene coming soon!

You’ll need to take your sensor/filmback size into account too.

Yes, I will absolutely do that :slight_smile:


Here is my scene and some pictures I took. Sorry for the shaky hands in one of them, but each red square on the measuring tape is 10 cm. The distance between the objects in real life is 50 cm. The distance to the camera from the first object is 60 cm in real life. The height of the objects is 12 cm in real life.

I have tried to copy this in Blender and have put in my sensor size and chosen the F-stop 1.8 that I also used in real life. I have not included the dog in the Blender file because as you can see I am not that skilled :wink:

The real life DOF is a lot shallower than in Blender. Have I changed some settings I should not have? And can someone see why the floor is so incredibly glossy? I downloaded a free Polligon-texture and followed the tutorial to set it up…

Thank you!

Blend file:

From my experience it’s best to leave Blender’s unit system in peace when it comes to rendering… This is your scene with units reset to meters (Blender’s base unit), all objects re-scaled to real world dimensions and all scaling applied:

Thank you so much!

That seems to be the problem actually. I had no idea that the basis unit system actually was already configured in meters. I thought it was just an arbitrary “Blender Unit”, but that may very well be from old versions and I have just picked that info up from somewhere.

Leaving the units where they are is a very nice way to avoid this problem. Now, I know it’s not actually on topic for this thread, but since we are already here - what’s up with the glossy problems I have with the floor material I wonder?

Yeah, well, that “Blender unit” actually never was arbitrary. Since Blender comes from a region using the metric system, a Blender unit has been equal to 1 m.

I might have been unclear with my latest post, though: You can very well switch the unit system to “Metric”, but avoid using the “Unit Presets” (other than “Meters”).

As for the floor material: The floor plane has unapplied negative scale, which caused flipped normals. You also connected the Alpha value of the GLOSS texture (instead of its color) to the material’s roughness. You might also want to connect that texture to the specular of the material as well.

Thank you again, this just fixes everything and I don’t know how I could have missed that!

But hey, fail forward!