Depth of Field not working in Cycles 2.9?

I’m following BlenderGuru’s donut tutorial, but I noticed the depth of field isn’t doing anything.
I even tried experimenting by setting the f-stop value to something crazy like 3000, but everything still seems in focus.

Does that mean that DoF works on versions other than 2.9 with that scene?
You have to use low F-Stop values to get the blur effect (You try something extreme to see if it works, for example 0.5). If it still doesn’t work, you share .blend file here to analyze it.

This depends on the dimensions in your scene, so values could vary a bit from that tutorial you followed.

Like in a real camera, increasing “f-stop value” makes more around the focus point in focus. Plenty of youtube tutorials describing how aperture works. I.e. f/22 will have a much wider (sharper) depth of field than f/1.2 (more blurry). Stay between 1.2 and 22 for what you’d find in normal cameras, maybe limit yourself to between 1.8 and 16 as extremes often comes with “issues”. On a large format camera, not for average consumers, you might go as high as f/64 for some very wide depth of field often used in nature/landscape photography. Below 1 you get into ultrafast and insane shallow depth of field - I’d just stay away - for safety :smiley: I.e. the Zeiss f/0.7 ultrafast is priced at $160,000, only 10 made, so not your average consumer style lens.

Ohh, I see now. Thanks!

I understand now! Thanks for letting me know! :slight_smile: