Despite matching FPS, VSE output audio not matched to video.

Currently working through Match Track Blend (version 01) with my shiny newish computer w/16 GB Ram on Windows 7. Have set my Sequencer / Clip Editor Memory Cache Limit to 8192.A

On rendering the first lesson (this one - - as found on my DVD), I found that the audio was out of sync with the video. Investigating, I found that when importing the original footage (from DVD, file ‘’, with Render Properties Frame Rate set to 25FPS) and then exporting as HDTV 720p at 25FPS, the resulting render (with no changes to content) has the audio rushing the video by about half a second.

The audio and video strips perfectly match each other’s position in the VSE. Everything indicates that it should output a video roughly equivalent to the video it imported.

In short, what in hell? Does anybody have a solution? Really wanted to get into some video editing, but it seems pointless unless I can solve this audio problem.


I had a look at this yesterday and to be honest, I have no idea what is going on. Playing back the video with QuickTime is fine, but even playback with mplayer or ffplay works ok. But in Blender it fails, indeed. This might be worth investigating. Maybe it is just a problem with this file, or with the VSE itself.
Maybe try with other video files for the time being?
BTW, one thing you should do when working with video and audio in Blender is to enable AV_Sync in the timeline (in your screenshot set to “No Sync”

Many thanks for taking a look at this, Mr. König! A couple of points in response:

  • I usually use AV_Sync in the timeline - just forgot this time as I was just trying to get a test render out and wasn’t altering the content. My understanding is that this only affects playback in Blender, correct?

  • The rendered file which is output on hitting ‘animate’ is named ‘0001-0881.avi’. I was playing this file in VLC - I didn’t try running the file through Blender.

  • On your advice, I’ll try the same process (import video into Blender, export video unchanged, test for audio) with some more video clips, including a selection from Match Track Blend.

Again, thank you for looking into this. I’m determined to match something, track something and, perhaps, maybe even blend something, someday. =)


So, as per your suggestion, have been experimenting with other videos to see if I can track down this problem. It’s been strangely erratic!

Firstly, I thought I’d look through the rest of the included MatchTrackBlend footage and imported the Leipzig 2-Point-Track vid. This isn’t so helpful as there’s no visibly synched audio in the file, but I did end up with a weird anomaly…

Despite importing the file at 25fps (as indicated by the VLC codec information page), the audio and video strips failed to match up!

I moved onto a clip from the film Grave Encounters… exvid-graveenc-sample.avi

This imported and exported perfectly (graveEncountersAudioTest0001-1724), with what seemed to be perfect lip synch.

Thinking it might be a problem with the .mov format, I downloaded a trailer for Fury Road -

This imported fine and - with some slight visual artifacts - exported perfectly, audio and video in sync.

Using VLC, I converted the original file from the one-point-track exercise into .mp4 and .ogg versions of the files - all of which imported perfectly (as the original had) and exported with the same out of sync audio video as the original (the video dragging slightly behind the audio).

Finally, I used Avidemux to convert the original file into .avi format - and lo and behold the video has the same out of sync audio problem… BEFORE I import it into Blender!

What on earth is happening? Do .mov files habitually have sync problems when converted to .avi? I’m really out of my depth here - any advice would be appreciated!


In Blender did you try creating proxy timecode (freerun) for the clip first? Also try converting to an image sequence (even from Blender) then import that over the top of the original and fade the clip 50% so you can see the mismatch. Will give you an idea about what kind of issue is occurring. Like single frame duplicates or group duplicates, perhaps even regular frame repeats showing GOP decoding issues.

GRARRARRRGH blenderartists just ate my first message.

So. Sorry about delay, been busy, thank you for responding to my panic, more later.

Main file has occasionally synced with audio when I change the proxy render size settings in the preview window, but seems to lose sync as soon as I change it again. This is rare and erratic. And annoying.

  1. Tried proxy timecode (free run). This seems to indicate that it should show black frames in either preview or exported animation - black frames turned up in neither.

  2. Exported video to images, reimported - partial success! Image sequence and audio sync perfectly in VSE and in exported video file run in VLC. Exported again with timestamp, exported original video with timestamp and - original video files don’t seem to sync to audio, as previously noted. Except -

The video track(s, the original and the original with timestamp) appear to have video frames at the start of the footage THAT DON’T SHOW UP in VLC media player OR the reimported video sequence channel. I can clearly see Mr. König raise his head and open his eyes before he begins to speak in the video track in VSE (the original or with timestamp).

In the original .mov (played in VLC) there appears to be a glimpse of these frames at the start of the video (for two frames?) and then he’s into his monologue (the same given at the start of thisyoutube video, though it’s missing the looking down frames and has a fade-up added at the start).

What on earth is happening? Is this just a screwed up video file? I’m enclosing a capture of VLC’s statistics page for the video…

I’m really confused here.

Sorry if I’m missing obvious content in this mail - as I say, BA ate my original note, so I might have forgotten to add something vital. Ask away.

And in passing - thank you for answering, 3pointEdit! And thanks for answering so many questions on this topic - you’re all over the BA forums on compositing/VSE etc! You’ve delivered a wealth of information to the forum - many, many thanks!


No worries, sorry I can’t make more sense of your problem.

Well, with that response - and assuming I haven’t just been unclear or unforthcoming with useful details - I’m happy to chalk this down to ‘huh’ and hope it doesn’t happen again (and if it does, convert video track to images).

Many thanks. =)