Did anybody try three.js 3d plug in for html5 and Blender 2.5?


The exporter does not show up on my side and I get this error message.
Blender Alpha 2 build 30117 OS X.

7/9/10 4:36:38 PM [0x0-0x146146].org.blenderfoundation.blender[2031] File “/Applications/Blender/Blender 2.5/blender.app/Contents/MacOS/2.52/scripts/modules/bpy_types.py”, line 580, in draw_ls
7/9/10 4:36:38 PM [0x0-0x146146].org.blenderfoundation.blender[2031] func(self, context)
7/9/10 4:36:38 PM [0x0-0x146146].org.blenderfoundation.blender[2031] File “//Applications/Blender/Scripts/io/export_threejs.py”, line 200, in menu_func
7/9/10 4:36:38 PM [0x0-0x146146].org.blenderfoundation.blender[2031] default_path = bpy.data.filename.replace(".blend", “.js”)
7/9/10 4:36:38 PM [0x0-0x146146].org.blenderfoundation.blender[2031] AttributeError: ‘Main’ object has no attribute ‘filename’

I was getting the same error here, on Ubuntu 9.10 with revision 30163.

Fixed it by changing “filename” in line 200 to “filepath”.

However… when I try to export the default cube, I get:

RNA_string_get_alloc: EXPORT_OT_three_js.filepath not found.

Even on my win7 I have the same issue.

File “C:\Users\claas\Desktop\Release\untitled.blend/export_threejs.py”, line 2
00, in menu_func
AttributeError: ‘Main’ object has no attribute ‘filename’
Traceback (most recent call last):
File “C:\Users\claas\Desktop\Release\scripts\modules\bpy_types.py”, line 580,
in draw_ls
func(self, context)
File “C:\Users\claas\Desktop\Release\untitled.blend/export_threejs.py”, line 2
00, in menu_func
AttributeError: ‘Main’ object has no attribute ‘filename’

— deleted —

what about : http://github.com/mrdoob/three.js/blob/master/utils/export_threejs_25b.py

This one finally shows up ad exports as well.

there is an rna error about filepath and name being unkown but it writes the file.

I’ve been having a little trouble implementing this.

I created a basic scene with Suzanne, which I unwrapped and baked AO to UV. I exported the model as “monkey.js” (object name: monkey) and the texture as “texture.png”. All that seems to work fine.

In the HTML file for my page, I have:

<div id="canvasContainer""> loading...</div>
<script type="text/javascript" src="monkey.js"></script>
<script type="text/javascript" src="display_monkey.js"> </script>
<script type="text/javascript"> init("canvasContainer", "texture.png"); </script>

By placing “document.write()” commands into “display_monkey.js” and observing what shows up on my page, I have learned that the script hangs on a line in the init function:

camera = new THREE.Camera( 75, canvasWidth / canvastHeight, 0.0001, 10000 );

Here’s where I am stuck. I’m not sure why this line isn’t working.

When I start up firefox in a terminal, refreshing my page gives the error:

*** NSPlugin Viewer  *** WARNING: unhandled variable 18 (<unknown variable>) in NPN_GetValue()

It was my understanding that this is a problem with firefox in linux 64 bit environments (which is where I have been working). However, the script stalls in the same place in Windows Vista-32 (using Chrome).

Any ideas?