Difficulty getting mesh deform modifier to work

After playing around with the chinchilla rig from Big Buck Bunny I decided to try the new mesh deform modifier myself. I created a simple arm, added a mesh (the cage) to modify the arm with and added a MeshDeform modifier to the arm. Then I copied the name of the deform (cage) mesh to the “Ob” field in the MeshDeform modifier and clicked the “bind” button. However the arm mesh is not deformed at all when I deform the deform mesh (I attached an armature to the deform mesh so that I can control it). What else do I need to do to get the MeshDeform modifier to work?

Make sure that all the meshes involved have had their rotation+scaling cleared/applied. Also, you need to be careful to make sure that the mesh to be deformed is entirely contained within the cage.

If this doesn’t help, try adjusting the precision values. Be careful, as it could easily consume a lot of memory (and take ages to compute)!

1 Like

I applied scale and rotation (CTRL+A) to the armature and both meshes. I also made sure that the deform mesh surround the arm mesh. Then I clicked the “unbind” button and “bind” again but MeshDeform is still not working. Next I selected the “Dynamic” option next to the “Precision” field for in case “Dynamic” needed to be selected. The last thing I tried was to change “Precision” from 5 to 10 which caused blender to crash.

Have you pressed on the “Bind” button?
Few days ago i was driving myself sick crazy with this deformer… then i noticed that button…

Yes I did click the bind button.

Attachments



Aha! Make sure that the cage mesh actually has faces. You can have it draw as if it doesn’t have any faces, but it is very important that it has faces for this to work correctly (ray-tracing used internally needs these to be able to sort things out)

I found something very interesting. I started a new blender project with a mesh deform modifier and this time it worked. However when I create a deform mesh by extruding a plane (Add/Mesh/Plane) the deform mesh does not work with the MeshDeform modifier. A deform mesh that start as a cube does work.

Aligorith I checked my original project’s deform mesh but as far as I could see the deform mesh has faces all over (I could not find any holes in it). But I think I started that deform mesh as a plane as well.

1 Like

But you don’t extrude/delete faces after its been deforming the actual character mesh, do you? Doing so will cause it to not work.

mikahl I finished the deform mesh and then clicked the “Bind” button in the MeshDeform modifier. But thank you for the warning I will keep that in mind.

Your first attempt was to try to deform the Armature and the Armature was then supposed to guide the mesh… Mesh has to be deformed by Meshdeformer, this seams logical (it is more or less supposed to replace IK animation in certain cases… or help performing some extra deformations i guess).
Actually, i’m about trying to create a caracter fully animated with Meshdeform and Shape Keys only… Let’s see what will poor out… :wink:

I finally found the problem. The normals of my cage mesh pointed inwards. I flipped the normals to point outwards and now it works.

So it was like Aligorith said: the mesh that will be deformed must be inside the cage mesh but with the normals pointing to the center of the cage what I assumed was inside was actually outside.

1 Like

I was facing the same problem, but it was fixed after I changed the “Precision” to 6 and yes using Precision of 10 caused Blender to crash.