Disable Bmesh or ngons or whatever?

It’s my understanding bmesh is responsible for the fact that whenever I subdivide a face it just adds a point instead of splitting the adjacent faces into quads and tris.

I need to turn this off.

Please tell me I can turn this off in 2.71.

There’s no disabling of Bmesh, Bmesh is the edit mode code that allows many tools to work.

For your subdivide problem, just after you subdivide a face, press F6 then enable “Quad/Tri mode”

You only need to make it once, any further face you’ll subdivide after that will have the Quad/Tri mode enabled already.

That will work. Thank god and you!

Working on game meshes with ngons achieves nothing but unpredictable ngon artifacts that love splitting too tightly.