Disabling the auto-zoom behavior of ISOLATE?

Oftentimes I find the auto-zoom that occurs when you ISOLATE an object to be counter-productive.

I especially find this inconvenient when texture painting a small feature, hitting isolate, and now I’ve got to figure out where I was in space because Blender zoomed all the way out.

We already have SHOW ALL (Home key) so I’m not quite sure how this zooming behavior is supposed to help users.

At any rate, I’d like the option to turn OFF the auto-zoom feature of Isolate. Just ISOLATE, viewport doesn’t change. Does this exist?

uncheck frame selected in keymap preferences

Thanks: I would have never found that.

In Paint mode it’s still zooming out. EDIT: I had to track down a couple more Keymap entries and disable them too.

How come the FRAME SELECTED area is ghosted when it’s first displayed??? Once you use it, either way, it’s displayed normally.

being ghosted means it is default setting and user didn’t set it himself
when there is X that means that default is overwritten by user:

1 Like