Displacement mapping Issue

I’m Attempting to use displacement mapping to add some surface relief to a NURBS surface I’m animating in blender and I have two qeustions:

  1. Where is the button/setting located in the interface that controls how much the Displacement map subivides the surface? It’s a little ‘choppy’ right now and I need to adjust it so is divides each quad further…

  2. In leu of finding an answer for Q # one, I simply created a more detailed mesh to displace using ADD: MESH: GRID. Only problem is, the displacement map is rendering out all these super ugly triangle polygon shapes on the surface of my object. Any Ideas?

This is for an animated map I’m doing, and I want some slight hills/valleys with actual geometric displacement. (That’s why I’m not using bumpmapping)

Thanks, Trevor

  1. there is none, you need to subdivide or subsurf it yourself.

  2. use greyscale or even better use propper Normal Maps (search Nvida site for info). Use a seperate channell. Turn down the Nor slider to zero.

You’ll get a much better result with Truedisplacement:



Displacement mapping can only displace the vertices in the original mesh. So if you have a plane with only four vertices (ie: not subdivided) then you’ll get no results from a displacement map.

The more vertices in your grid, the better the results, but the longer the render time and the more memory you’ll need to render the image. The jagginess you describe is probably due to too few vertices, not using smoothing, and maybe a result of an displacement map that has sharp variations in tone between adjacent pixels.

My solution for your problem is:

  1. add->mesh->plane
  2. apply a material with clouds texture (experiment here - try different procedural textures - esp. Musgrave with fBm - for more realistic terrain)
  3. map the clouds texture to disp and set the disp sloder to some value - try 0.3 for starters - lower may be better
  4. now the important part - turn on subsurf for the plane with simple subsurf (instead of Catmull-Clarke) selected. The higher you set the subdiv number the less jaggy your terrain will look

You may also want to select the plane and click the Set Smooth button so the terrain will have a more smooth appearance.

The subsurf subdivision will max out at 6 - and for terrain that may not be enough. If not, then subdivide the plain two or three times manually with the subdivide button in edit mode and then use subsirf on this.

Note that you’ll need to increase the second (rightmost) subsurf subdivision level button. Beware, though - you can create a lot of polys using this method, especially if you subdiv the plane a few times first.

This should fix the issues you describe, if I have understood correctly.

Kinda correct, but slightly not - displacement works on renderfaces. When Blender renders, it converts all geometry in the scene to renderfaces, which are then rendered. For example the ‘render’ subsurf number field controls how many renderfaces are generated.

For a NURBS object, like the original poster is using, the tesselation can be controlled by the Resol U and V number fields - the higher, the more the NURBS is subdivided.

Quoting myself :slight_smile: :

Turn the Nor slider of the texture which has displacement on, to 0. If you want bumpmapping too, put this in another texture channel, because displacement- and bumpmapping in the same texture channel mess eachother up.

Thanks guys, This was all very helpful. I have a much better understanding of how displacement works in blender now, and all my problems are solved. (well, I still have severe eyestrain, but I don’t think blender can do anything about that :stuck_out_tongue: )