Display speed is slow


I’m seeing choppy display rotation speed with Blender 2.49b and 2.5.2 at full screen (1920x1200 display resolution). If I make the Blender window very small (maybe 1/4 the screen size), the tumble and pan speeds become smooth. This is all with just the default cube in the scene.

Here are the specs for OS and card:
Quadro fx 4800
Windows 7 x64

I’ve tried a few fixes so far but no luck…

  • made display 16 bit instead of 32 bit
  • disabled Anti-Aliasing
  • let Blender decide it’s graphics settings versus global control from the card
  • changed prefetch frames to 1 instead of 0 in Blenders OpenGL settings
  • increased the MEM cache limit
  • updated the Quadro driver

I use other CAD programs (like Rhino) on this system daily.

Does anyone have any thoughts on fixing this?

Thanks a lot,

Check to see if anything is running other than Blender; Ctrl + Alt + Delete than Applications.

Thanks for the suggestion but that didn’t effect anything… same staggered tumbling with only Blender running.

This is awful weird…
In 2.49b:
In your render settings (“F10” for Scene tab, “Format” section), set the frame rate to as high as it will go (120fps IIRC)
In the User Preferences window, View & Controls tab, make sure the “Playback FPS” in the “Display” section is depressed so Blender will display the animation frame rate.
Then, with your mouse over the 3D window, hit ALT+A and see what the frame rate is.

With your vid card, you should get right at 60fps (or whatever your refresh rate (Hz.) is set for on your monitor… which, in effect, “caps” your frame rate). It sounds like you may be getting much less… if you are, and you say your using the latest/greatest vid driver, then you should try a complete re-install of the driver… completely remove the existing (and any previous) drivers using something like Driver Cleaner or Driver Sweeper in safe mode to make sure all registry entries are deleted and all other driver detritus is removed. Then re-install your driver.

I have an old GeForce 5200FX that pegs at 60fps @ 1680x1050 with much more than the default cube?!?!

Thanks Ran13, I ended up having to uninstall and reinstall the Nvidia driver but things are tumbling smoothly now. The Alt-A frame rate test was something I didn’t know about. Interestingly, the count got just as high before and after my reinstall (250) but the time it takes to count that high is much faster now.

Thanks again for your help.

For anyone else who ends up having this same issue with an nVidia card…

The problem went away for me after installing fresh drivers as I posted but then appeared again after a restart. I ultimately found that Blender does not like a feature in this nVidia card called “Vertical Sync”. Turning this off seems to have solved the slow display tumbling.