Does anybody know why procedural texturing is so laggy?

I’m using Eevee and it lags when I zoom into my material, trying to find a way to make scratches on my model, I was following this tutorial.

TheRoyalSky’s video quickly gives you a solution, but none of the “why am I doing it this way” behind the solution. And certainly not necessarily the most optimized solution.

It is really hard to read the settings on your nodes, but if you are using 4D noises at detail level 16 (the max), your GPU is likely going to have a bad time. Try turning down your detail levels.

See this twitter thread by Bartek Moniewski, whose handle on this site I can’t seem to find.

2 Likes

Thanks, I’ll definitely take a look.

1 Like